Kawasaki ZX-10R Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi all,

I own a 2005 zx10r with 71 K miles on it.
My problem is that the bike can not rev up more than 9-10 revs in any gear, except the 1st one so I can not use all it's power.
Do you have any idea what it can be or did it happen to you?
I recently changed the oil filter and air filter with original Kawassaki parts.

It might be the fuel pump or fuel cable that is not stretch or any thing else you can think of?

Thanks a lot!!!!
 

·
Registered
Joined
·
642 Posts
My first thought with a engine that has 71k was to do a leak down and compression test.

Other then that has all service been done and up to date on the engine?

You can test the fuel pump.

Are there any aftermarket products on the bike? Power Commander etc.
Disconnect and see if any changes.

That's a start.
 

·
Registered
Joined
·
3,872 Posts
Like mention above you can check the fuel pump make sure its working properly. Also if your bike has a pc disconnect that to rule out that could be the problem. Few other things to check could be the sidestand switch and plugs.
 

·
Registered
Joined
·
1,030 Posts
Sounds a lot like what mine was doing when the fuel pump was bad
 

·
OMG Look at that squid!!
Joined
·
2,595 Posts
Im voting fuel pump or power commander.
 

·
Registered
Joined
·
1,669 Posts
Sounds like air or fuel, check the filter and intake path for obstructions and disconnect the PC and let us know. Then hook up a fuel pressure tester if you have one.
 

·
Registered
Joined
·
123 Posts
Hi all,

I own a 2005 zx10r with 71 K miles on it.
My problem is that the bike can not rev up more than 9-10 revs in any gear, except the 1st one so I can not use all it's power.
Do you have any idea what it can be or did it happen to you?
I recently changed the oil filter and air filter with original Kawassaki parts.

It might be the fuel pump or fuel cable that is not stretch or any thing else you can think of?

Thanks a lot!!!!

If the problem started immediately after performing this work you need to check your work. Air filter housing cover on correctly (sealed)? Obstruction in ram air, engine overfilled with oil? Fuel line pinched or routed incorrectly?
 

·
Registered
Joined
·
5 Posts
I had that problem one time come to find out it was low fuel pressure...what I did was pull the pump out the tank and take the pump and filter (black box) apart get some carb or brake cleaner and spray it down in the filter let sit and blow out with air compressor do that till it runs clear out (it'll probably look rusty at first) now look on eBay and get you a $20 pump .. I clean out the filter once a year now just for maintenance..hope that'll work
 
1 - 10 of 10 Posts
Top