Kawasaki ZX-10R Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
hello everybody,

im new to the forum so a couple of words about myself. im polish currently residing in south london... ive had a 10r i converted into a track bike a couple of years ago... last year on a track day the bike stalled... i mean as weird as it sounds the bike's electrics died with me doing 120 mph... on trying to start it the f1 light kept coming on... took it to the local garage and they found the battery had cracked and leaked... probably due to one of the offs earlier... i bought a new battery but the problem persisted... f1 flashing the bike wont start... i was told the ecu has been damaged (me trying to charge the faulty battery)... i recently bought and identical ecu (serial nr and what not).... so i was advised...i was told i need to send the new ecu with the keys to the ecu people so that they are coded together or such....sorry i saoun a bit layman but thats as acurate as i can get...
many thanks for any replies

michal
 

·
Registered
Joined
·
1,486 Posts
That info is correct, the European version of the ZX10r used a immobilizer that was built into the keys. There should be 3 keys to the bike if memory serves me, 2 regulars and the immobilizer master key.

They prob need to be sync'd to the new ECU for the bike to fire up.
 

·
Registered
Joined
·
2,658 Posts
If the bike showed an FI light in the first place, you have to find the error code.
Do you know the error code number, or how to find it?

You bought a new ECU or a used one without keys?
 
1 - 4 of 4 Posts
Top