Kawasaki ZX-10R Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
Hi

I was wondering if you guys could help me out with my 2016 zx10r (kit ecu + harness setup)

Recently i changed my starter motor and unplugged the air box + throttle body

Since then i dissasembled and assembled the bike 3 times to make sure everything is correctly plugged and seated

My dash still blinks like crazy. I even tried the clearing procedure but not sure if it is working with the kit ecu

I can start and ride the bike like normal and even use quickshifter

Below are the videos of the error and error codes


 

·
Registered
Joined
·
314 Posts
verify the two connectors around the tps area are not plugged in incorrectly (swapped) im pretty sure the two connectors are exactly the same, also search for error code 16 as seen in your video, looks like its related to the IAP sensor which you seem to have unplugged and replugged back in, if you disconnected the ecu at some point verify all the pins look good, etc. It would be a good idea to post this in WERA forums here - Tech. Tag @DDK732 in your post and he should chime in fairly soon if he's not helping some of the riders at the motoamerica event this weekend. He was Andrew Lee's and Richie Escalante's mechanic/crew chief last couple years and is a test rider for Kawasaki USA, super knowledgeable guy and has helped me several times with obscure issues.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #3 ·
Thanks alot, much appreciated

I also forgot to mention that i turned the ignition on after installing the new starter motor and tested if it turns while leaving everything else unplugged. Not sure if that caused havoc on the system
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #6 ·
Oh sorry one more question, by ecu clearing itself you mean that i have to ride few cycles to let it sort itself out ( like the stock ecu) or is it more or less instant ?
 

·
Registered
Joined
·
314 Posts
Oh sorry one more question, by ecu clearing itself you mean that i have to ride few cycles to let it sort itself out ( like the stock ecu) or is it more or less instant ?
no just a simple power cycle i would think

 
1 - 7 of 7 Posts
Top