Kawasaki ZX-10R Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
hi i have a 2010 zx10r 8700 miles no power comander that flies up to 10000revs but then struggles to rev any higher theres no fi light on so no codes anyone have any ideas thanks
 

·
Registered
Joined
·
771 Posts
Have you removed your fuel tank lately? If so, checked for a pinched fuel line when you put it back on.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
havent had tank off but will check any way but wouldnt that make it lose power as revs get higher rather than fine up to 10000 then suddenly not rev any more
 

·
REPOST Enforcement Mod
'16 ZX-10R KRT
Joined
·
15,727 Posts
havent had tank off but will check any way but wouldnt that make it lose power as revs get higher rather than fine up to 10000 then suddenly not rev any more
Nope. The Gen 3 was the first of the ZX-10s to use the secondary injectors. With 8 injectors, the top 4 pick up in high RPMs while the lower set drops out. You have a fueling issue. Either a fuel pump problem or a fuel flow problem. If the secondary injectors don't have the proper flow and pressure, the engine will top out at a certain RPM.

But please tell us that you aren't revving the shit out of the motor in neutral to test this. That's the worst thing for a motor. Ugh!
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
thanks that seems to make sense happened while riding wouldnt rev it like that parked up, is there a fuel filter and how do you check pump also what revs do secondary injectors start to take over
 

·
REPOST Enforcement Mod
'16 ZX-10R KRT
Joined
·
15,727 Posts
thanks that seems to make sense happened while riding wouldnt rev it like that parked up, is there a fuel filter and how do you check pump also what revs do secondary injectors start to take over
There is a fuel filter! The problem is it's built into the pump housing. It's not cleanable or serviceable. At least not according to the engineers. Some people have had good luck taking the filter out and replacing it with a Suzuki filter, but it's not something that's documented readily. Take it to a shop and they'll just replace the whole pump. That's the quickest and easiest thing to do.

You'd have to hook up a pressure tester to the outflow line of the pump housing and test the fuel pressure that way. But the pump is the typical reason these types of problems occur.

The primary injectors start to shutdown at about 8,000 RPM while the secondaries start to increase at that point. There's a crossover range around that mark where one set shuts down and the other picks up as the RPMs increase.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #7 ·
hopefully a nipped fuel line if not i'll get fuel pump tested at dealers, are they known for failing its not done many miles, also will it harm secondary injectors if they are not getting correct fuel flow
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #8 ·
had a play today air filter was fairly mucky tried to clean it but didnt get much out so ordered a new one but took it for a test run and found if you slightly back off throttle when it bogs at 10000 you can get it up to 12500 then it pulls hard into redline it has recently had an akrapovic can put on could this be the cause and just needs setting up on dyno
 
1 - 8 of 8 Posts
Top