Kawasaki ZX-10R Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
209 Posts
Discussion Starter · #1 · (Edited)
Hi all

Only posting this as problem has got worse.

Last oil change few days after bike started whistling at about 2k rpm, whistle today got much louder

I cant pin down source, sounds like it's from right side of engine....happens if clutch enaged or not

Few ideas I had..

Bearings in generator ?
Mis fitted air box ?

I took it to kawasaki dealer when it fitst started and they said it was nothing, now this whistle / whine is much much louder.

Bike is 06 ZX10

Any clues would be appreciated, search turned up nothing

Cheers
 

·
Registered
Joined
·
209 Posts
Discussion Starter · #3 ·
i had the airbox off two days ago to take flys out... maybe it's not seating snug on throttle bodys
 

·
Registered
Joined
·
166 Posts
Hi all

Only posting this as problem has got worse.

Last oil change few days after bike started whistling at about 2k rpm, whistle today got much louder

I cant pin down source, sounds like it's from right side of engine....happens if clutch enaged or not

Few ideas I had..

Bearings in generator ?
Mis fitted air box ?

I took it to kawasaki dealer when it fitst started and they said it was nothing, now this whistle / whine is much much louder.

Bike is 06 ZX10

Any clues would be appreciated, search turned up nothing

Cheers
Why would you care?? Who does 2k rpm anyway:heyyou:
 

·
Registered
Joined
·
209 Posts
Discussion Starter · #6 ·
broke down last weekend, no output on alternator, batt then died and ECU etc not running.

turns out whistle was the stator coil slowly breaking up and burning out.

new one in and she all good again....old one was a charred mess.
 

·
Registered
Joined
·
582 Posts
broke down last weekend, no output on alternator, batt then died and ECU etc not running.

turns out whistle was the stator coil slowly breaking up and burning out.

new one in and she all good again....old one was a charred mess.
Mine did the same thing... 4 months ago. :dontknow: It seems that they are fragile, as well as the regulator / rectifier.
 

·
Registered
Joined
·
1,276 Posts
man..I posted this SAME question the other day and only got a couple suggestinos....

Read my thread would ya fluke. I'm going to see if I can get it on video...but I dont know if the mic will pick it up over the motor.

http://www.zx-10r.net/forum/showthread.php?t=77344
 

·
Registered
Joined
·
209 Posts
Discussion Starter · #11 ·
Hey man, just replied in your thread but sounds exactly the same thing. Your gonna need to inspect the stator coils

I didn't do the job, got kwak dealer to do it, but they also did a precautionary oil / filter change also as there was alot of junk splattered around in the generator housing

They gave me the old stator after, and it was charred / burnt on several coils.
 

·
Registered
Joined
·
209 Posts
Discussion Starter · #13 ·

·
Registered
Joined
·
1,276 Posts
fluke....did it sound like a slide whitle kind of? I just used some electronic ears to try to pin point it. I need to take the left side fairing off to get deeper into it but it sounds like its coming form right arond the coolant overfill tank. Just a tad over 2000.. like 2100 it makes the noise.

How much did it cost? I'm going to have to do mine on my own. You'd think it would last more then 10k miles!!!!!

I pulled the filter..and welll, its getting a new one. didnt change the noise but its dirty.

Oh yeah... the stator cover...its dry in there right? No oil? I think it is but I dont remember.

How many miles are on your bike?
 

·
Registered
Joined
·
1,276 Posts
This is the 1st time I have read about it. I searched here and came up with a bunch of helmet threads.

I wonder if Kawi has a recall on it??
 

·
Registered
Joined
·
209 Posts
Discussion Starter · #17 ·
fluke....did it sound like a slide whitle kind of? I just used some electronic ears to try to pin point it. I need to take the left side fairing off to get deeper into it but it sounds like its coming form right arond the coolant overfill tank. Just a tad over 2000.. like 2100 it makes the noise.

How much did it cost? I'm going to have to do mine on my own. You'd think it would last more then 10k miles!!!!!

I pulled the filter..and welll, its getting a new one. didnt change the noise but its dirty.

Oh yeah... the stator cover...its dry in there right? No oil? I think it is but I dont remember.

How many miles are on your bike?
Hiya

Yes sounded like a whistle, starts at 2000rpm and by time your at about 3.5k rpm it is too hard to hear but still there in background.

It sounds like from by res as thats where the generator is... there is no oil under the cover as it all spins on crankshaft but sealed away from engine, but once you take cover off I think you need a sealant to put it back / new gasket.

I paid £350 UK for stator new coil / gaskets / some other bit / oil and filter + labour. Bike had 21,000 miles on it.. maybe should of done myself but I left it to experts
 

·
Registered
Joined
·
321 Posts
Whistle I have this sound too.

Going on this thread I think I have found the problem this will be my second stator coil pack.
My 1st engine burnt one out abut 17k before second one lasted about 30 thousand miles its still in my dead snapped crank motor but it was whistling for a few thousand miles before crank snapped.
Why are they doing this is there a better replacement ?
 
1 - 18 of 18 Posts
Top