Kawasaki ZX-10R Forum banner

21 - 31 of 31 Posts

·
Registered
18 zx10r
Joined
·
651 Posts
Probably a bad batch. I haven't had any issues jacking up my bikes from the header weld areas. I'm buying a pair of pit bull jack stands now though. Much easier to keep the front up to service the stem bearings and the rear to remove the swingarm and shock.
 

·
Registered
Joined
·
144 Posts
Discussion Starter · #23 ·
Probably a bad batch. I haven't had any issues jacking up my bikes from the header weld areas. I'm buying a pair of pit bull jack stands now though. Much easier to keep the front up to service the stem bearings and the rear to remove the swingarm and shock.
Jacking the bike on the header? Yikes!

I’ve lifted bikes by using straps around the rafters but never jacking on the header.

My assumption is that the header collector failed from the heat and stress of racing. Maybe from being wide open for extended periods at Daytona? So far the replacement has held up, we’ll see if it withstands Daytona this fall.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
109 Posts
Holy thread revival, but I think I have the same issue on my 17RR now. Hearing a strange “ticking” that doesn’t change sound quite linearly with rpm. I’ve spend a bit of time doing top speed stuff being WOT for decent periods, and I think she may have finally let go.

ETA: also noticing my afr reading aren’t particularly consistent anymore.
 

·
Registered
Joined
·
144 Posts
Discussion Starter · #27 ·
Holy thread revival, but I think I have the same issue on my 17RR now. Hearing a strange “ticking” that doesn’t change sound quite linearly with rpm. I’ve spend a bit of time doing top speed stuff being WOT for decent periods, and I think she may have finally let go.

ETA: also noticing my afr reading aren’t particularly consistent anymore.
No problem with the revival because quite honestly, I just had my 2nd one fail. My Arrow Exhaust full system is shipping Friday. I don't see any way to fix this issue other than getting rid of the factory system. The collectors are a weldment of various pieces which seem to be failure prone, at least in race situations. I'm not hopeful for a great bump in HP from the aftermarket system but I am expecting that I will never have to replace it again barring physical damage. My last used OEM cost only $200 but replacing it and having to keep tabs on it seems like too much work.
 

·
Registered
Joined
·
109 Posts
No problem with the revival because quite honestly, I just had my 2nd one fail. My Arrow Exhaust full system is shipping Friday. I don't see any way to fix this issue other than getting rid of the factory system. The collectors are a weldment of various pieces which seem to be failure prone, at least in race situations. I'm not hopeful for a great bump in HP from the aftermarket system but I am expecting that I will never have to replace it again barring physical damage. My last used OEM cost only $200 but replacing it and having to keep tabs on it seems like too much work.
Did the 2nd one fail in the same place? I haven’t been able to figure out exactly where mine is. I’m wording if it’s up where the 4 pipes come together, I notice I have some rocks stuck in between there, and I’m thinking the heat cycling and vibration may have worn one of those rocks through.

You shouldn’t see but 1-2hp peak hp with a full system vs 3/4, but you should see a very nice 8-10hp bump in the mid range.
 

·
Registered
Joined
·
144 Posts
Discussion Starter · #31 ·
Did the 2nd one fail in the same place? I haven’t been able to figure out exactly where mine is. I’m wording if it’s up where the 4 pipes come together, I notice I have some rocks stuck in between there, and I’m thinking the heat cycling and vibration may have worn one of those rocks through.

You shouldn’t see but 1-2hp peak hp with a full system vs 3/4, but you should see a very nice 8-10hp bump in the mid range.
Did the 2nd one fail in the same place? I haven’t been able to figure out exactly where mine is. I’m wording if it’s up where the 4 pipes come together, I notice I have some rocks stuck in between there, and I’m thinking the heat cycling and vibration may have worn one of those rocks through.

You shouldn’t see but 1-2hp peak hp with a full system vs 3/4, but you should see a very nice 8-10hp bump in the mid range.
Yes, they both failed at the collector.


Sent from my iPhone using Tapatalk
 
21 - 31 of 31 Posts
Top