Kawasaki ZX-10R Forum banner

1 - 20 of 6082 Posts

·
Registered
Joined
·
662 Posts
Discussion Starter #1
Stolen from another forum!

Like the title says, what did you do to your bike today?

The other night I calibrated speedohealers on my ZX10 and my wifes R6!
Then I pulled the mufflers on both in anticipation of the slip-ons I ordered coming in today!
 

·
Blitzkrieg
Joined
·
4,473 Posts
i typically walk by mine as it sits in the basement covered up with the battery tender plugged up.....weather has been sh!tty.
 

·
Registered
Joined
·
33 Posts
i installed a clutch cable only to realize that wasnt my problem so then i removed my clutch cover and found my problem!! part will be here tomorrow!!
 

·
Registered
Joined
·
667 Posts
Leaving work JUST after sunset last night, I realize neither of my lights are on.

Not having any tools, and living 20 minutes away, I decide to go for it.
Going probably an average of 95 MPH to make it home before dark, I just made it.

So last night I changed the fuse.
 

·
Registered
Joined
·
3,152 Posts
Leaving work JUST after sunset last night, I realize neither of my lights are on.

Not having any tools, and living 20 minutes away, I decide to go for it.
Going probably an average of 95 MPH to make it home before dark, I just made it.

So last night I changed the fuse.
You could have stopped at a gas station and bought a fuse :heyyou: I had my lights quit on me at 11 at night after filling up. I rode across the street bought some fuses and was on my way with lights working.
 

·
Registered
Joined
·
2,123 Posts
making some Pair block off plates, waiting on the BMC race filter & Ohlins shock to show up and installing a solo seat cowl...

This is on Triumph 675 though, as well only i bike i have in oregon.
 

·
Registered
Joined
·
180 Posts
well I attempted to install a Danmoto exhaust around 12 in the morning. Well word to the wise "You Get What You Pay For!" the damn slip on didn't "Slip" on at all! It doesn't fit right at all. Once you clamp everything down properly it sits right on / above the swing arm! Thus resulting in a damged pipe and damaged swing arm. So I decided to rotate the pipe outward a lilbit, and now the pipe hits the rear peg! Also the damn bolt that comes with the provided clamp broke in half while installing.... I have no pipe on my bike meanwhile >(
 
1 - 20 of 6082 Posts
Top