Kawasaki ZX-10R Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
So here's the jist. I installed my Taylormade exhaust and PC5 last night. When I started her up the FI Light was on, red warning light, yellow flashing warning light, traction control lights 1-3 blinking, and gear showed 6 no matter what gear I was in. However, she ran like a raped ape. I also think the wheelie control might have stop working because it sure was hard to keep her down today :)

Any thoughts or anybody else experience this?

How do I pull the codes?

Thanks for the help!
 

·
Registered
Joined
·
1,357 Posts
make sure you made all the plugs corectly and a good ground for PC5, update PC5 fireware, download file from power commander
 

·
Registered
Joined
·
343 Posts
Confirm that you plugged the TPS plug into the correct place on the throttle bodies.

There are two plugs on the right hand side, one grey one black. they are a PITA to get to. And the one you need to plug it into is the one on the bottom. You need to use the black one.

Bellow is a pic of my throttle bodies, lifted, you can see the grey and black plug and the cable going up to intersect the black connector. If you fitted your PC5, with the throttle bodies in place, there is a chance you may have used the top plug (they are both the same shape)

 

·
Registered
Joined
·
545 Posts
assuming you did the installation correct and ruled out what turbor1 mentioned, it is almost definitely the firmware... I had a similar issue with my installation and it turned out to be the firmware that came installed on my pc5 outta the box wasnt the most recent thus causing all sorts of issues.... once I updated the firmware all issues ceased. here is a link to firmware updates : http://www.powercommander.com/powercommander/Downloads/powercommander_downloads.aspx?ProdType=PCV

hope that solves it, let us know. cheers.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #8
You guys are life savers. I'm thinking it's what Turbo1 mentioned. I'll tear back into her tomorrow and check. Hopefully it's an easy fix! Took her to the track tonight and confirmed my traction control was off...

I'll let you know how it goes tomorrow!
 
1 - 9 of 9 Posts
Top