Kawasaki ZX-10R Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
So, I've looked through thousands of posts hoping to find some help on my problem....I have a Vortex rear brake Pressure switch with my vortex rear sets. About a week ago, while riding I figured out that my brake light is coming on and staying on! I have it narrowed to the rear switch, I was just wondering if anyone has ever had this kind of problem with these, and if so, how do I fix it??
 

·
Supercharged Mod
Joined
·
4,388 Posts
Replace the switch with a new one. They're not all that expensive to buy separately ($20-ish IIRC) so it's not worth trying to repair.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
I was just hoping someone might have a quick fix...no one around here actually stocks them, and I have to have it working to ride on base. O-well, guess I'll just order a new one!
 

·
Certified SLOW
Joined
·
3,131 Posts
Man do they do a walk around of your bike before you get on base or something? That's nuts. Either way, it's not very safe to be riding with your brake lights constantly on. Stay safe, and good luck.
 

·
Registered
Joined
·
452 Posts
also check the pedal adjustment on your brake pedal. may just be not set correctly for enough slack for pressere switch.
 

·
Registered
Joined
·
203 Posts
take it off.

take the preasure switch off until you can get a new one and put a regular brake nut back in the master. You never use the rear brake without the front brake anyways, quick fix until it comes in. Then you can ride. takes 5 minutes.
 
1 - 6 of 6 Posts
Top