Kawasaki ZX-10R Forum banner

1 - 16 of 16 Posts

·
Currently Clueless
Joined
·
1,516 Posts
Discussion Starter #1
:iamwithst Has anyone here had to change their valve cover gasket? Mine is leaking and it is not because of loose bolts. I am thinking of doing it myself and need to know how hard it is and if I have to drop the engine to accomplish it. Any feedback would be great. Thanks
 

·
Supercharged Mod
Joined
·
4,391 Posts
It is a hassle, but you do not need to remove the engine from the frame.

You need to remove all of the components that are necessary to do a valve clearance adjustment, because the valve clearance adjustment requires removal of the valve cover, and with the cover off, the gasket is right there.

Remove: Seats, all bodywork except the tail section, fuel tank, airbox, throttle body and EFI assembly, radiator has to be loosened and shifted forward, front engine mounts on both sides, ignition coils, air suction valve, and about 1500 plug-in electrical connectors along the way. Then you can remove the 6 bolts that hold down the valve cover.
 

·
Yankee Racer
Joined
·
14,838 Posts
I did it and it really didn't take that long. Just took out the manual and got er done and put back together in about 4 hours. Really it wasn't all that bad and I have never done anything like this before so I am sure you can. By the way what side is it leaking from? Mine was leaking a little from the right side only after a heated track session. I cleaned it all off and resealed it and haven't had a problem since. Oh yeah and I only had around 4,500 miles at the time
 

·
Yankee Racer
Joined
·
14,838 Posts
Slims10R said:
:idea: Thanks for the info while I am in there I am also going to change the plugs.
That'll be a good time to do it since it's a pain to change the plugs anyways. i should mention my mileage was all pretty much hard track miles though
 

·
Registered
Joined
·
3,311 Posts
It isn't that bad except getting the TB out and then the stupid black rubber thingy.
Mine was leaking after I did the thin head gasket so I just slopped a little silicone caulk into it and all was good.
 

·
Currently Clueless
Joined
·
1,516 Posts
Discussion Starter #11
It is leaky from the forward let side,Kawa didn't bother to tell the dealer that it was back ordered so it just shipped today so I won't get it till monday.But got the plugs changed. It was defiantly a pain in the arse getting the TB out, the manual says there are only 4 connecters that need to be unplugged but theres like 4 underneath that need to be unplugged also.But got em out and just waiting.Thanks for all the info guys.
 

·
Registered
Joined
·
3,311 Posts
Finding some of those electrical connectors is a PITA, they are really under there on the bottom right side
 

·
Yankee Racer
Joined
·
14,838 Posts
Also since the gasket is reusuable you could just clean it up and reseal it. This is what I did as I had a few races and couldn't get the part in time. It has not leaked at all and has been great since, and I have done another 2,000 miles of trackdays and races
 

·
Currently Clueless
Joined
·
1,516 Posts
Discussion Starter #15
So I got it done it took me a total of about 8 hours.I replaced the spark plugs and just did some general maintance. The hardest part was unplugging and plugging in the TB connectors but will find out today if it is gonna leak so hear goes nothing.
 
1 - 16 of 16 Posts
Top