Kawasaki ZX-10R Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
163 Posts
Discussion Starter #1
I need to do something with my clutch. I am not sure what... either change springs or change clutch but something has to be changed. When I launch my bike, I am getting severe chatter. I pull the clutch back in a tad and let it out and it seems to grab better and the wheel comes up. Happens every single time. I dont mind the wheel coming up, that issue can be addressed but the chatter issue is a problem. It either bogs, chatters, or wheel comes right up at the launch. There is no in between to float the clutch like I could do on other bikes and carry the front wheel from the launch until it settles.

Obviously we are talking about drag racing here. Stock clutch has about 4k miles on it. 07 ZX10R. Best I can pull is a 1.9 60' I have video of my launches to show you what I mean. You cn hear me launch the bike, I can feel it chattering then I slip the clutch back in a little and it slips and grabs nice.

If it matters, I am using a mobil1 syn 10-30 oil.
 

·
Registered
Joined
·
1,764 Posts
First off make sure you clutch basket doesn't look like this



If it doesn't, Call dwayne at concept cycles and order a clutch for a 2004 zx10r WITH judder spring.

Or you could try soaking them in oil to see if it helps.

When you put the 04 clutch in DON'T put the 2 big washers back in.
 

·
Registered
Joined
·
3,851 Posts
like codyc said check your basket to make sure you dont have any groves or notches in the basket where the plates fit. also a good upgrade i see alot of gen2 owners doing is switching out the stock basket for a gen1.
 

·
Registered
Joined
·
779 Posts
I welded my basket together to disable the slipper function, no more problems. I do have Barnett springs
 
1 - 5 of 5 Posts
Top