Kawasaki ZX-10R Forum banner

21 - 25 of 25 Posts

·
Registered
Joined
·
8 Posts
Here's the one I have.


I've only had it a month so far, but I have nothing bad to say. It plugs right in out of the box, with no wiring mods whatsoever. While not necessary for normal operation, the programmable features are awesome.
 

·
The Pace
Joined
·
7,096 Posts
Michelin Road 2s. Had about 1200 miles on them, still were looking good. And no, the ride home was NOT slow :badteeth:
Mich NOT good. The fabric belts. Pro riders always report Mich tires acting stupid all the time. rs10 and metz m7 might've stayed together but rim may still bend if you're running low psi. I do have to run psi about 34/34 on one oily crappy loop, but run normal 41/41 on other loops.
 

·
Registered
2014 ZX10R
Joined
·
25 Posts
Discussion Starter · #24 ·
Here's the one I have.


I've only had it a month so far, but I have nothing bad to say. It plugs right in out of the box, with no wiring mods whatsoever. While not necessary for normal operation, the programmable features are awesome.
Thanks. Do you need to buy any of the recommended accessories for it to work? All I care about is that the rear brake and turn signals work, don't care about the other features.
 

·
Registered
Joined
·
8 Posts
It works just fine out of the box, but since the turn signals are led they will flash faster than usual. That is a problem with all integrated lights and most aftermarket led signals, and is easily solved using an electronic flasher. Customled sells them, but I forgot to order one when I got my tail light.

Fortunately, I was able to pick one up from my local Cycle Gear. They didn't have one for a Kawasaki in stock, but the Yamaha flasher they had on the shelf plugged right in without any mods.
 
21 - 25 of 25 Posts
Top