Kawasaki ZX-10R Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
97 Posts
Discussion Starter #1
Hey guys/gals.

my 05 throttle cables are stiff or seem to have resistance compared to pretty much any other bike I have tested. Off throttle to on throttle is jerky and I'm sure that is partially do to it being FI but still very jerky. Using silicone spray I have lubed the cables, routing is good, cleaned and lubed the TB springs and it still feels stiff. Bike has 20'000km and was poorly taken care of so just looking for some advice before I pull the throttle bodies for cleaning and replace the cables.

Thanks in advance.
 

·
Registered
Joined
·
1,624 Posts
Check the throttle housing to see if it's binding. Sounds like you have checked everything else. It's probably ok but worth a look. Disconnect the cables from the housing and see if it rotates smoothly. You could also disconnect the cables from the throttle bodies and see if the cables are binding when you turn the throttle. If their not binding could be the throttle bodies are causing the issue.
 

·
Registered
Joined
·
97 Posts
Discussion Starter #3
I removed the entire system and it all seems to work properly with no load, apply load and you can feel the drag and hear a slight grind. Its fairly smooth and returns normal but not nearly as smooth as I think it should be. Thanks for the reply.
 

·
Registered
Joined
·
1,624 Posts
Like you said above bike was poorly maintained. The throttle bodies could need a good inspect and clean. Sadly
 

·
Registered
Joined
·
626 Posts
Maybe your bike has a 1/5th turn throttle insert that you aren't aware of. I noticed that my throttle became stiffer after installing the insert.
 
1 - 9 of 9 Posts
Top