Kawasaki ZX-10R Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
256 Posts
Discussion Starter #1
Okay guys so I have an 08 zx10r, and it has always done this since the day I bought it used....I leave the bike hooked up to a battery tender and if I leave it sitting for 24 hours or more then come out to start the bike, I turn the key wait then hit the ignition button...it'll start to sound like it wants to start while my fingers pressed, I let go and it stops...I hit the button again and it immediately fires up perfectly....this happens every time and my starter motor went bad. Got another start motor and it still does it. Is this something I should be concerned about?


Sent from Motorcycle.com Free App
 

·
REPOST Enforcement Mod
Joined
·
14,338 Posts
Do you wait for the instrument cluster to finish it's self-test before hitting the button? The sound you hear when you turn the ignition on is the fuel pump priming the fuel rail. You shouldn't thumb the starter until the fuel pump and instrument cluster finish the self test.
 

·
Registered
Joined
·
256 Posts
Discussion Starter #5
Apparently there are 2 recalls for my bike
1- electrical system-battery
( my battery isn't the stock one so don't know if that matters )

2- electrical system- alternator/generator/regulator


Sent from Motorcycle.com Free App
 

·
REPOST Enforcement Mod
Joined
·
14,338 Posts
Apparently there are 2 recalls for my bike
1- electrical system-battery
( my battery isn't the stock one so don't know if that matters )

2- electrical system- alternator/generator/regulator


Sent from Motorcycle.com Free App
Yeah, the recalls are pretty well documented, but won't affect the starting of the bike. Did you get that video yet?


Sent from Motorcycle.com Free App
 
1 - 8 of 8 Posts
Top