Kawasaki ZX-10R Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi everyone, new to the forum. I am in the process of using a C1H engine in a project. I bought the engine on its own with no wiring or throttle bodies, it was a spare track day engine for someones bike but he had a bad accident so sold everything. Since then I have been picking up bits as and when, I got an original wiring loom with ignition barrel but no key, the same guy had the throttle bodies so got those too, got the last little bits but my one has the immobiliser system built in and with no key it makes it useless. I found the pdf for the race kit with the wiring diagram in it for the race loom, as the engine is going into a car I dont need the lights so took that wiring out and started converting the loom to the slimline race setup meaning I cut out the ignition barrel, before I started this process the engine wouldnt turn over, now I have the engine turning over but it does not seem to fire the injectors or coils. Has anyone else done this? Can the engine run on standard ecu with the loom cut down to follow the race version? Is the race kit ECU wired differently inside or is it just a difference in maps with the ability to be modified?

Any help would be greatly appreciated (expecting to be told Ive buggered it up)
 

·
Registered
Joined
·
49 Posts
You are going to need a resistor inline one of the wires at the ignition key switch. There is a 20-gauge GREY wire that runs from the ignition switch directly to the ECU. The white wire at the switch bundle of wires is the 12v from the battery. The brown wire is the ignition on wire so you can put your ignition toggle switch or whatever between these wires. You want to tie that grey antitheft wire into the brown wire but with a 1/4 watt 100ohm resistor in between them so the signal back to ECU is dropped to the appropriate voltage. Without this, the engine will not run. You can get the resistor at radio shack.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks for the reply, I should have put its a UK spec which doesnt have the grey wire running directly to the ecu, I only have a Brown, White, Red/Blue and Red wire from my ignition switch, but I have cut that out now so that it always has ignition on. I am now using the right hand switch to turn the engine over or cut the power using the kill switch as it shows on the race kit wiring diagram.
 
1 - 3 of 3 Posts
Top