Kawasaki ZX-10R Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
353 Posts
Discussion Starter #1
I got my Pitbull stands the other day along with some PBR spools. When I was adjusting and lining the rear stand up with the spools I noticed that it looked like the spool holders on the stand would grind into the swingarms if I were to try and crank the bike up onto the stand. I was just wondering what you guys are using for spools on your 06/07 10R with pitbull. I have the forward handle rear stand setup. Kind of a weird problem...the vendor that sold me the setup seemed surprised and he left me with the impression that he talked to Pitbull, and they said the spools he shipped should work fine...kind of an odd situation...Any thoughts? :dontknow: When I look at it, it just looks like bad grinding related things will happen if I go ahead and try and lift the bike up...

Cheers
 

·
La Flama Blanca
Joined
·
7,727 Posts
Get the champs spools they are ofset on the left side so it gets the stand a little aways from the swinger, I have not had any issues with this setup.
 

·
Bloo Moderator
Joined
·
23,742 Posts
Any Pics on the "forward handle rear stand setup"...I can give you advice on mine but not sure we have the same thing :dontknow:
 

·
Registered
Joined
·
376 Posts
I have a similar problem with my spools. My rear handle pitbull stand sometimes touches the swingarm when lifted. I'd like to know more about CHAMPS spools.
 

·
Registered
Joined
·
353 Posts
Discussion Starter #6
I have a similar problem with my spools. My rear handle pitbull stand sometimes touches the swingarm when lifted. I'd like to know more about CHAMPS spools.
Yeah man, I hear yah...fortunately I noticed that it was going to rip into my swing arm before I actually cranked the bike up on the stand. It looked close but I wasn't willing to take the chance. They originally shipped me some 10mm spools, which is what Pitbull suggests for the stand when used with the 10R. This is bullshit for sure. I had them ship me another set of spools that gained me another 8mm of clearance just to be sure...perfect...

Cheers
 

·
Registered
Joined
·
2,215 Posts
Some of the problem is on Kawi. The mounts are welded to the swiingarm. Granted it is much better on the 10R than it is on the ZRX. The spacing is not always consistant and one side sticks out from the center of the tire more than the other. The 04-05 is closer to being the same on both sides than the 06-07. Plus you may need some clearance for the ?? welding. If not the spools could sit crooked and dig into the swingarm. But no biggy, Honda is just as bad. lol
 

·
Registered
Joined
·
376 Posts
Some of the problem is on Kawi. The mounts are welded to the swiingarm. Granted it is much better on the 10R than it is on the ZRX. The spacing is not always consistant and one side sticks out from the center of the tire more than the other. The 04-05 is closer to being the same on both sides than the 06-07. Plus you may need some clearance for the ?? welding. If not the spools could sit crooked and dig into the swingarm. But no biggy, Honda is just as bad. lol
I did a little searching and couln't for sure find which spools you make. Could you post up a pic of yous please?
 
1 - 10 of 10 Posts
Top