Kawasaki ZX-10R Forum banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
5,179 Posts
Got my SpeedoHealer from CalSportBikes Friday but I had to work all weekend and didn't get to install it until tonight. Before I started I looked on www.speedohealer.com and this site for a how-to that might give me some tips & tricks and some ideas of how to route the cable and where to mount the box. I found nothing. The ZX-10R install "tutorial" on speedohealer.com is a broken link and using the search feature here didn't turn up anything useful.

So, with nowhere else to turn except postin' up questions and waitin' for answers I grabbed the shop manual and some tools and tore into it. I took some pics in hopes that they might help others who might buy the healer not knowin' how/where to mount it. Enough bullshid, here's the how-to...

First thing I do before tacklin' any project is get that beeyotch up on some stands to steady it and get it up off the floor makin' it easier to get to the low stuff. Here's a pic before I removed anything...





First thing that came off was the clutch side lower. The speed sensor cable connection that the SH plugs inline into is behind the lower...





Here's a closer view of the speed sensor cable/connection with it's protective boot. There are two cables/connections with identical boots. Finding the speed sensor cable/connection is as simple as tracing the cable from the speedo sensor to the connection. The other cable/connection is for the gear position switch...





At first I plugged the SH in below the metal strap that retains the two cables/connections. I originally thought I'd prolly mount the SH box underneath the seat with the battery...






After some thought though I decided to try and put it up around the dash so I could take advantage of the top speed button and maybe make future adjustments without havin' to remove the seat. I found that leavin' the connections below the strap left me enough cable to reach up around the ram air box/upper area but it sort of limited where up there I could mount the box. So, I went back, removed the strap, fed the connectors thorough it, reinstalled it and fed the cable up alongside the big wiring harness that goes to the upper beneath the clutch side mid and upper fairings. Here's a shot after I redone the connection above the strap. Made for a cleaner install and gave me more cable to play with...





With the cable sorted out and routed to the dash area it was time to mount the box. I almost mounted it to the clutch side of the bottom half of the ram air tube between the frame and upper but that left a bit too much of that red cable shinin' for the world to see. It wouldn't have been that bad, I just prefer a cleaner install. So, after some playin around I found the perfect spot for it. I mounted it on top of the clutch side headlamp housing on the fairly flat area above the dust cover. To mount it I used black Velcro Brand Industrial Strength velcro hook & loop material. Both the back of the SH box and the headlamp housing surface were cleaned with denatured alcohol to clean them for ultimate adhesion of the velcro material adhesive backing. Here's a shot of the SH box with the velcro (with backing still on)...






Here's a shot with the SH box mounted on the headlamp housing. From this angle you can see how the cable is routed beneath the upper and looped up so that it hides against the upper along where the mirror mount brackets are. The red cable is visible from this angle but I had to position the camera in a funky way so that you could see it. Ya have to be just right and have good lighting (my huge shop light stand was on) to be able to see it...






Here's a shot from a normal viewing angle standing by the bike. The SH box is visible with the shop lights shinin' on it but with out the added light it all but disappears in this location when yer just walkin' around the bike. I thougth this location worked out very well. It's hidden from weather and direct sunlight but still within easy access if I want to see my top speed or need to adjust or test it...






Here's a shot showin' how I routed the red SH cable along the bigger factory wiring harness that goes up front...





The SH comes with two zip ties to secure the cable to other wires and/or brackets. Here's a couple pics showin' where I used the zip ties. The first one is to a bracket up near where the SH cable meets up with the big harness in the above pic. The second one is up near where the SH cable and big harness go underneath the upper fairing...








Lastly, here's a couple shots with "natural" garage lighting showing how well the SH and cable hides in that location without direct lighting pointed in there on it...







The only thing I have left to do is re-install all the plastics. I programmed in -12% based on what I've read posted on this forum by others with a 16t front sprocket. I hope to get a ride in tomorrow and verify it via GPS. I'm thinkin' I'll shoot for accuracy at around 75-80 mph and let anything higher fall where it may.

So, whatta ya think of my install? Hope it comes in handy for those of you who have yet to buy and install one. I'd like to have had somethin' like this to base my install on, but Hell I like figurin' shid out on my own anyway. It's a good stress relief for me to tinker around with stuff like this. I'm sure most of you know what I mean...

Peace...
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top