Kawasaki ZX-10R Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
76 Posts
Discussion Starter #1 (Edited)
I have read the how too on this site but it doesnt give me a good idea how to remove the conecter gaurd thats on the inside stock conecters. Its giving me some problems and doesnt want to come out. Is there a trick that anyone has done to make the removal of this peice easier. I just dont want to use a ton of force and break it. any help will be much aprisiated.
 

·
Registered
Joined
·
169 Posts
I have read the how too on this site but it doesnt give me a good idea how to remove the conecter gaurd thats on the inside stock conecters. Its giving me some problems and doesnt want to come out. Is there a trick that anyone has done to make the removal of this peice easier. I just dont want to use a ton of force and break it. any help will be much aprisiated.
I can't picture in my head which connector you are referring to. Do you have, or can you take a pic of the one you are talking about? From memory, I don't recall having an issue with the Speedo Healer install. Now the GIPRO on the other hand...
 

·
Registered
Joined
·
854 Posts
I used a pair of needle nose pliers and squeezed both side of the guard to get it off. If you try that it should work without any issues. :thumbsup:
 

·
Registered
Joined
·
76 Posts
Discussion Starter #4
The peice i was thinking of was that white connector protecter on the inside of the stock wireharness conecter this is a speedo healer V4 on a 07 zx10. thanks for the advice on the needle nose pliars ill give that a try and see if it removes it. thanks agian for the feedback
 

·
Registered
Joined
·
551 Posts
I used a small screwdriver between the outer housing and inner white protector and carefully "bended" it out bit by bit. It is connected with small "hooks" below, so it has to be "lifted" out.

Once the protectors are out, "flip" the connectors forward with a screwdriver, and they'll loosen. Then downwards to get them out.

I too was fidling a bit with this, as the manual isn't really clear about how to do this.
 

·
Registered
Joined
·
1,775 Posts
I just used a small long skinny flat head to push it and the wire unlocks and eaily comes out of the harness plug, if tha't's what your talking about
 

·
Registered
Joined
·
76 Posts
Discussion Starter #7
Thank you everybody for your advise i just did it took me about a hour or so to do it. Now the question is i used the calulator they had online and they said i should correct it by -10.8% is that a good one to use. i have an 07 with -1 up front and stock out back with a 190/55 on the rear anyone have a more accurate calibration or is the -10.8 good enough?
 

·
Registered
Joined
·
1,775 Posts
Sounds good to me. Also depends a little on the tire life. IF you wanna get anal check with GPS, but then you might be dead on at 90 then 1 to 2 off [ or more ] at 130. Will this really drive you nuts? Honestly test it out for your self. I am sure you will be happy. IF you have to make adjustments to suit your tast I am sure it won't be much. Good luck! :thumbsup::eek:ccasion1
 

·
Registered
Joined
·
1,775 Posts
I am doubting this :dontknow: but is there any difference from the thin head gasket link you set me to the Attack one that is double $$$? I am thinking there's is prolly a OEM one as well.




Whats a est cost for the dealer to put in the Cam and Head Gasket for me? Will they degree it for me or is that one the guy on the Dyno is going to do to get it perf while tuning? Never messed with this so this is why I am asking.
 
1 - 9 of 9 Posts
Top