Kawasaki ZX-10R Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hey all,

Im new here, semi new owner of an 05 10R in Pearl Orange..

This my second road bike ive owned as ive come from a motocross back ground ( TL1000R was my first bike ) and im loving the bike.. She scares me sometimes :wink:


It has a Kawasaki Race ECU
Kawasaki Race Cam
PCIII Dyno Tuned
DNA Air Filter
Emission plates modified etc
Arrow Muffler




Have since Added smoked integrated tail light and double bubble which has made the bike look alot nicer.

Anyway, to my delimma
But sometimes after i switch it off after riding then try to restart soon after she just turns over and wont fire, its happened a few times now and its starting to piss me off.

Anyone else had similar issues with thier 10?
 

·
Registered
Joined
·
128 Posts
great choice on your first bike!! i had an 01 Tiller too! god i loved that thing.

anyway i havent had any issue with my 10 except for recently after it set in the cold garage for a bit..it cranked a bit to get it fired. but still purred like a kitten..or tiger whichever.

ever had plugs changed or the other owner have problems with fouling them? could be fuel fouled from all those different gadgets and the ecu. just my .02 cents
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
hey dude,

i thought it couldve been plugs so i did a full service on the bike, changed the plugs, cleaned the air filter etc and still it happened the other day

Its summer here so the fuel is always getting used, im riding the thing every day. It doesnt happen all the time just the odd occaision.
 

·
Gone
Joined
·
673 Posts
welcome, great colour, never seen that on the rods in the uk, just on here, but were going to get the 08's in orange...
 
1 - 4 of 4 Posts
Top