Kawasaki ZX-10R Forum banner

1 - 20 of 34 Posts

·
Registered
Joined
·
2,006 Posts
Discussion Starter #1
ok so i finally got the bike i have always wanted and it has turned into a nightmare.

i bought a 04 10r from a guy east of atl last weekend.

when we got there dude was out getting one last ride in and when he pulled up on the bike he shut it off, when he turned the key back on the starter started engaging and would not stop till he turned the key off, but when he hit the start button it would fire up and run fine. (should have walked away right there but i really wanted this bike because of the list of mods) but i figured what the hell. we took the bike up to his garage and started messing with it trying to figure it out. well in the process the battery went dead. (really should have walked away i know)

we got the bike running and i checked it with a multimeter and it seemed to be charging so i figured a new battery and figure out the starter problem. i figured what the hell and put it on the trailer.

so i got the bike home and put a new battery in it and rode to my friends house, well on the way home the bike died (ffffuuuuuuuuccccccckkkkkk)

got my neighbor to bring the trailer and pick me up and brought it back home. checked it out and sure as hell it's not charging. i ordered a stator for it and when it came in we started tearing into the bike and when we got down past the throttle body we found a burnt up wire so we fixed that and decided to put it back together just enough to start it and see if it would charge before we tore it all the way down to get to the stator. well we put her back together and turned the key on and it did its normal started engaging crap and wouldnt fire up. well this time when i turned the key off it wouldnt stop spinning the starter until i unhooked the battery. so i called it quits for the day and ordered a starter relay figuring that was my problem.

so yesterday my relay comes in and it is back to trying to start as soon as you turn the key but at least it will stop when you turn the key off and still wont start.

i can unhooh the starter relay to the starter and can hear the fuel pump prime and everything seem to come on as normal when i turn the key on but when i hit the button to try and start it, it doesnt fire up like it was.

anyone have any ideas on any of my problems. i am pulling my hair out

here is the mods list of what is done to the bike

Mods include,
Motor:
Port/Polished Head
Titanium Retainers and springs
Kawasaki Race Cams
Angle cut valve job
Shaved Head
All Crankshaft work done.
Kawasaki Clutch Replaced 2500 miles ago
Removed butterflies and secondaries
Shallow Oil Pan
Low 1st Gear Mod
Full TiForce Titanium Exhaust
Dynojet PCIII
Dynotuned by Chris Hill at Performance Psycles in Knoxville,TN

Drive Train:
Vortex Sprocket -1/+2
EK Chain
Michelin Pilot Power Tires

Add ons:
GPR Steering Dampner
Strapped front end
Stretched and lowered
ZX-14 Front Brakes
Stainless Steel Brake Lines
Ceramic Wheel Bearings

Accessories:
Custom Made Rear Seat Cowl
Carbon Fiber Mirrors
Double Bubble Windscreen
 

·
Registered
Joined
·
2,006 Posts
Discussion Starter #2
nobody huh

i would settle for ideas on why it wont fire up and run. that would be a great start.

come on guys i NEED to ride
 

·
Servo's Eliminatus ;)
Joined
·
6,813 Posts
Pick you up a main wire harness off eBay. I picked one up for 35 bucks from cycle reapers.
Replaced it and have no more problems.
 

·
Registered
Joined
·
1,929 Posts
Congrats, you will be jacked once its all fixed. You forgot the most important info, so we all know how fast it really is - color (hint blue was the fastest color that year)
 

·
Registered
Joined
·
2,006 Posts
Discussion Starter #5
yeah I've got a ride it a little bit and it is silly fast but it doesn't matter how fast is if I can't get it to run

I don't want to have to replace the whole harness because it was a race bike in there is a lot of stuff eliminated

if I can just figure out the starting problem I think I will b ok
 

·
Registered
Joined
·
1,527 Posts
Its more than likely not going to affect anything but I would disconnect your PC3. Get rid of all your variables. And what was the wiring going to that was burnt?
 

·
Registered
Joined
·
2,006 Posts
Discussion Starter #7
k I will try that thanks for the reply the wire was 1 of the wires going from the stator assembly to the rectifier
 

·
Registered
Joined
·
249 Posts
get yourself a schematic of the starting circuit on that bike, and if you understand electricity at all..it should be pretty easy to run through the components on paper and figure out where to look and what to look at. like as if the key was completely out of the ignition and the bike was still trying to turn over, you may have a short making up with something staying in contact. but you understand the concept of relays correct? low current control ckt's control higher current power ckt's. you may find that you have more than one issue, as is commonly the case. so do the lights and dash stay lit when you remove the key and the bike continues to try to start? or is it simply the starter and thats it? questions like this help you look in the right places...cuz if it's a problem that affects the lights and horn and such too...then you could be looking more toward an issue with the ignition switch, if they go off, then you may be looking more toward a relay or the starter solinoid. happy hunting!
 

·
Registered
Joined
·
2,006 Posts
Discussion Starter #9
that's why we tried to just put it back together to see if it would start in charge because we thought that may have been the charging problem
 

·
Registered
Joined
·
249 Posts
could be something as simple as a closed start switch too...although when you turned the ignition off it wouldn't keep going. only way it can keep turning when you take the key out is if the starter solinoid is still closed...and only way that can be closed...is if it's either stuck together somehow(burnt, bad spring, etc) or if you still have control power somehow powering that solinoid. that's it...so with that said, you know that the solinoid is in full time when you turn the key on cuz it keeps trying to start...so if you can access it, test for voltage on the control side of the solinoid...(i don't have a schematic but i would assume the start switch is before the solinoid so therefore there would be no potential at the solinoid's control terminals). If you find that you don't have voltage at the control terminals, then you have a solinoid that is stuck in, if you do find voltage, then you know you have control power coming from somewhere, the trick is finding out where. start switch? short from another ckt? i dunno. just some info to get you started.
 

·
Registered
Joined
·
2,006 Posts
Discussion Starter #11
I did replace the starter solenoid and now it only tries to start when you turn the key on when to turn off to stop trying to start but I believe it something with a starter not with the key switch

I think it is somewhere between the start button and the starter cylinoid

also don't make fun of my spelling I'm using speech to text on my phone lol
 

·
Servo's Eliminatus ;)
Joined
·
6,813 Posts
I don't want to have to replace the whole harness because it was a race bike in there is a lot of stuff eliminated

if I can just figure out the starting problem I think I will b ok
Then you need to ask the last owner what modifications were made to the wire harness on the bike. Cause something is seriously AFU if it is doing that shit.

And even with it being a race bike, the wire harness shouldn't have been altered that much. I mean what are they gonna alter, the lights??

I still say replace that harness, 35 bucks is a cheap fix.

If you don't mind me asking, what did you pay for this bike?
 

·
Registered
Joined
·
2,006 Posts
Discussion Starter #14
well guys once again thanks for all the replies.

so i figured out the starting problem. it was a plug under the main plug on the right side of the throttle body we missed pluging back in. plugged it back in and she fired right up. rigged up a toggle switch to engage and disengage the starter for right now. i know i have my ghetto moments but what the hell i really want to ride.

now the only problem that i have left that i cant deal with is i have all lights except the headlights (yeah kinda need those) any ideas

thanks again for all the help so far guys
 

·
Registered
Joined
·
452 Posts
Then you need to ask the last owner what modifications were made to the wire harness on the bike. Cause something is seriously AFU if it is doing that shit.

And even with it being a race bike, the wire harness shouldn't have been altered that much. I mean what are they gonna alter, the lights??

I still say replace that harness, 35 bucks is a cheap fix.

If you don't mind me asking, what did you pay for this bike?
:+2:

If it was a race bike and the install the kawi race ecu, it doesn't have hook ups for head lights or the connectors were cut of of stock wiring haness....Get a new wiring harness..:dontknow:
 

·
Servo's Eliminatus ;)
Joined
·
6,813 Posts
Hey cookmaster30,
Let me know if you need any of the plugs (connectors).
I have all the ones from the harness I took off my bike.
 

·
Registered
Joined
·
2,006 Posts
Discussion Starter #20
thanks guys but i have most of the issues kinda dealt with.

let me rephrase the race bike part. when i say race bike i just meant the motor has been built and when they did, the eliminated alot of vacuum lines and looks like taped a few sensors and stuff off. so i dont mean track bike race bike where you get rid of all the lights and stuff. this is the maxton mile bike that was for sale on here awhile back.

anyone have any ideas on the headlights. every light including the little daytime running lights work except the headlights. i checked the fuse. i also kinda checked the plugs up by the headlights. any other ideas what to look for
 
1 - 20 of 34 Posts
Top