Kawasaki ZX-10R Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
559 Posts
Discussion Starter #1
I've had this problem with my bike if it is indeed a problem,it backfires when I decelerate... now that I recall this used to happen occasionally since about 3 years ago. Now it is backfiring almost all the time when I decelerate and/or pull the clutch in. I got to admit that bluefish flame coming out of my TBR looks pretty cool,albeit drivers behind me are like 'Whoa'! Nevertheless,I've heard it may be an indication of something not so good at play.

Yet another issue I have been negligent about is the smell of gas every time I ride. Now before you make a crack,I know there is a smell of gas regardless when you ride,maybe? But,it is a little overwhelming... my clothes smell like it after each ride (as of late I only ride from home and to work and a few errands here and there). Could this have something to do with the backfiring? I wanted to mention that about 1 1/2-2 years ago,I must have overtightened the left side panel screw because it made a hole in the gas tank that had to be welded. That is when I first smelled the strong smell of gas (obviously because of the leak) but had smelled it ever since even after the weld. Unfortunately,my son will be born soon so I'm going to be tied up a bit,but I do plan on having her checked out soon.

Any advice on where to start trouble shooting would be of great help. Thanks guys!
 

·
Registered
Joined
·
3,765 Posts
have you did the pair valve mod ? that will eliminate alot of that poppin your hearing if you havent. also check the weld on the tank to see if its leaking gas there and fuel lines that connects to tank, if dats not it might need a tune from runnin to rich.
 

·
Squid wannabe
Joined
·
6,073 Posts
Backfiring is normal.
Like said you can get rid of it by doing the pair valve mod.
Gas you shouldnt be smelling, get that weld checked out. How many miles are you getting out of a tank of gas?

And post up some pics of your bike, it looks pretty nice in your avatar.
 

·
Registered
Joined
·
376 Posts
Could it just be running very rich? My bike used to run so rich till I changed the fuel mapping. Made my clothes smell like I had been riding my 2 stroke mx bike all day long.
 

·
Registered
Joined
·
559 Posts
Discussion Starter #5
have you did the pair valve mod ? that will eliminate alot of that poppin your hearing if you havent. also check the weld on the tank to see if its leaking gas there and fuel lines that connects to tank, if dats not it might need a tune from runnin to rich.
I have not done that mod... idk what it even is but will look into it... like I said I don't mind it much. I have checked the weld and that area has rusted... I will check the gas lines but last time I checked about a month or less ago I did not see anything. I will look again.

Backfiring is normal.
Like said you can get rid of it by doing the pair valve mod.
Gas you shouldnt be smelling, get that weld checked out. How many miles are you getting out of a tank of gas?

And post up some pics of your bike, it looks pretty nice in your avatar.
From a full tank I'm probably getting 80-90 miles. I ride only 5 days a week,total about 4 miles round trip each day. It seems like I get less and less mileage... thanks. I think I have some in my albums.

Could it just be running very rich? My bike used to run so rich till I changed the fuel mapping. Made my clothes smell like I had been riding my 2 stroke mx bike all day long.
Yeah my clothes smell like I rolled around in a shallow pond of gas. I'm considering having a custom dyno map done... I've been quoted at $350 from Attack Tuning in Huntington Beach,CA...

I'll look into the valve mod and have it check out ASAP. Thanks
 

·
Squid wannabe
Joined
·
6,073 Posts
You might be leaking some gas. I can get about 110 out of a tank, but again, different riding styles, different gas ranges.
 

·
Squid wannabe
Joined
·
6,073 Posts
115 highway sounds about right for me...
I dont think you leaking gas then
 

·
Registered
Joined
·
559 Posts
Discussion Starter #9
That was about 3-4 years ago though... hey anyone know what the standard sprocket sizes on a 06 ZX10R are?
 

·
Registered
Joined
·
3,765 Posts
I have not done that mod... idk what it even is but will look into it... like I said I don't mind it much. I have checked the weld and that area has rusted... I will check the gas lines but last time I checked about a month or less ago I did not see anything. I will look again.

yea do a search its plenty of write up about this mod. also i would recheck all the fuel lines comin from the fuel tank and throttle bodies to make sure there is no leakage there. if you dont discover nothing then maybe its time for tune bro.
 

·
Registered
Joined
·
763 Posts
When i first picked up my first gen used i had an issue of smelling gas. Searched around and found nothing. About a week after i purchased it i had it idling in the driveway and when i threw a leg over it i noticed a bit of gas on the driveway. Turns out the o-ring to injector #1 had failed and was slowly spewing gas. It was an easy fix, but if it hadn't pooled like that it would have been a pain to find.
 
1 - 12 of 12 Posts
Top