Kawasaki ZX-10R Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
can anyone tell me what the fuel pressure is supposed to be on an 04 ZX10. my bike seems to be shutting on and off only @ full throttle but runs fine while cruising? Any help would be appreciated.
 

·
Registered
Joined
·
3,204 Posts
not sure of the pressure, but sounds like your pump is going back since it idles fine. and i got one for sale =}
 

·
Supercharged Mod
Joined
·
4,388 Posts
Prime suspect is a bad fuel pump ... Common problem ...
 

·
Registered
Joined
·
30 Posts
Discussion Starter #4
I checked the fuel pressure last night and just turning the key on it has 45 lbs but thats not saying anything about full throttle.
 

·
Supercharged Mod
Joined
·
4,388 Posts
When the pumps go bad, they stop delivering sufficient volume. They'll give enough at idle and low revs, but they can't keep up at high revs and load. That's how mine went.
 

·
Registered
Joined
·
3,204 Posts
I tried to email you back about the pump at the jcamaro email but it wouldn't let me. I sent you a PM nonetheless.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #12
shutting off 04 ZX at full throttle only!!!

Ok i really need help with this one!!! my bike runs great except for full throttle its not modified no power commander or anything. I have replaced the fuel pump, throtttle position sensor checked all sensors and connections kick stand switch you name it ive touched it and the bike runs fine except when you peg it and it just shuts of like someone hit the kill switch and then comes right back on.
ANYONE HAVE ANYYYY IDEAS Please help!!!!!!!!!!
 
1 - 13 of 13 Posts
Top