Kawasaki ZX-10R Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello,
This is my first post after buying my first zx10r, which is having real issues, so I would appreciate the benefit of your experience. I have ridden for 8 years and worked on heli's in the Marines so I have a fairly technical background.

It is a 2009 ZX10R with 7000 miles:
The secondary fuel injectors (most notably the third one) seem to come on at start-up and stay on, bogging the bike badly. It won't idle. There is a notable amount of fluid built up on the intake valves, which I can see by looking through the intake manifolds (worst is the third). The third exhaust pipe is notably cooler than the others. It smokes white out of the can.

Recent maintenance:
The previous owner did a tuneup: plugs were replaced. I have resistance checked the plug boots as well as the secondary injectors, which all read fine. I even unplugged the secondary injectors from their harness, and still get fuel from the third injector.

Background:
I purchased a bike that started and idled in the driveway, but when I got it home and on the road it bogged bad in all gears.

Please help! I tried to include any pertinent info!

Thank you all! I hope to be a long lasting member here on ZX-10r!
 

·
Speed Freak
Joined
·
12,730 Posts
sounds like a clogged fuel injector!

for $25 a pop you can have them cleaned by hopefully someone close to you, I know there is a shop in mid florida MPS that flow matches the injectors.

Does the bike happen to have any tuning hardware like a power commander on it?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
update

Well... that's what I'm going to have to find out from the dealer.

The bike was vandalized days after I purchased it, so I didn't have a good point of reference, but it has the original stock air filter and can on it, so I assume that it doesn't have an aftermarket tune done.

I decided to run it through insurance today after speaking with the dealer, who told me that it could be largely electrical/ECU related. On top of that it has some gashes in the paint from the vandals, which, coupled with the parts/professional labor I may need, bring the total above my deductible.

I haven't seen many/any threads on this kind of problem, so I'll post what the dealer finds.

Also, the Gecko is going to backdate the work I've already had done due to the vandalism, which is good news, and something I didn't know they did.

Thank you!
 
1 - 3 of 3 Posts
Top