Kawasaki ZX-10R Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
235 Posts
Discussion Starter #1
Hi

The sato slip on has been just installed to my 2005 ZX10R bike...the quality is exellent...but the upper spring is touching to the the pipe !!!

Any experiences and recommendations ? What to do....

At least I will remove that plastic shelters...
 

Attachments

·
MIA Post Whore
Joined
·
8,727 Posts
Leave the plastic in place. It's there to prevent noise from the springs. The touching is not a problem.
 

·
Registered
Joined
·
1,405 Posts
My Sato setup looks the same, except I don't have the sleeves.

I like the Sato, but have to admit the mid pipe could fit a bit better. Can you move your pipe back and forth? Mine doesn't fit as tight as the Yoshimura RS-3 did.
 

·
Registered
Joined
·
34,537 Posts
the spring position and rub is normal for many systems & brands.

BD
 

·
Registered
Joined
·
6,354 Posts
Leave the plastic it will help prevent fretting from the spring. Without it it will start rubbing the metal and eventualy rub a hole into it.
 

·
Registered
Joined
·
1,007 Posts
My akro is the same....no worries bro just get out and let it growl!
 

·
Registered
Joined
·
373 Posts
circusnuts said:
My Sato setup looks the same, except I don't have the sleeves.

I like the Sato, but have to admit the mid pipe could fit a bit better. Can you move your pipe back and forth? Mine doesn't fit as tight as the Yoshimura RS-3 did.
just put one on too and pipe does move a bit. Never used the silicon, so maybe its something to do with that
 
1 - 7 of 7 Posts
Top