Kawasaki ZX-10R Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
345 Posts
Discussion Starter #1
I tried the Purolator ML16818 at my last oil change. In my case, the threads seemed to be just different enough that I couldn't get it to spin on. That may be my error, but I gave it up and bought a Kaw branded filter which did spin on ok. I pass this on FWIW.
 

·
Registered
Joined
·
34,537 Posts
Mmmmm, there are a couple of Purolator filters that work but from my understanding the Pure One W/part# PL14610 (blue) is their top of the line filter. The standard filter is L14610 in white.

BD
 

·
Banned
Joined
·
125 Posts
Is this for a ZX10R ? If so that is the wrong filter number . That number you listed is a type 2 filter . The Kawi , Honda and Yamaha use the type 5 . Nothing wrong with Purolator filters . You just had the wrong one . The ML 16818 has 20 X 1mm threads . The CORRECT Purolator PL14610 has 20 X 1.5mm threads . That is why your filter would not spin on .

Again the Purolator number you need is the Purolator PL14610 .
 

·
Registered
Joined
·
345 Posts
Discussion Starter #5
tberd said:
Is this for a ZX10R ? If so that is the wrong filter number . That number you listed is a type 2 filter . The Kawi , Honda and Yamaha use the type 5 . Nothing wrong with Purolator filters . You just had the wrong one . The ML 16818 has 20 X 1mm threads . The CORRECT Purolator PL14610 has 20 X 1.5mm threads . That is why your filter would not spin on .

Again the Purolator number you need is the Purolator PL14610 .
Yeah, it's a 10R and I got the number I used from a member here. Owell, at least I didn't force it. I'll note the numbers quoted and use them in the future. Thanks.
 
1 - 8 of 8 Posts
Top