Kawasaki ZX-10R Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I purchased this zx10 about 3 months ago and have been fixing it while the riding season is coming. I have this gap above the rear integrated tail light that I can't seem to fix. I thought it might have been a bent rear tail but everything was in check when I removed all the fairings. It almost seems as thought the matte under-tail portion is just a little low but if I try to pull it up to match the gap, it bends and looks unnatural. Any suggestions???:dontknow:
 

Attachments

·
REPOST Enforcement Mod
'16 ZX-10R KRT
Joined
·
15,726 Posts
Welcome to the party!

Unfortunately you're dealing with a half-ass install from the previous owner. That tail section piece is one complete unit. It looks like the didn't take the time to disassemble the tail pieces properly and install the light. So they just cut the top piece off. How the attached it is beyond me. But the gap you're seeing is a problem with the top section of it and the cut line. How to fix it "properly" would be to replace the entire aft tail piece. Other than that, you're going to have to take it apart, monkey around with it to see how they have it connected and come up with a way to trim it down some so it sits flat.
 

Attachments

·
Registered
Joined
·
29 Posts
I mis-installed my integrated tail light on my 2018 XZ10r this past weekend and I had quite a big gap as well at the top of the light and below the rear tail. My issue was that the top of the light has a groove that is supposed to slip over a part of the tail and I had the groove below the slot rather than on the slot. The fix took 10 minutes and now my taillight looks great. Not sure if your issue is similar, but I thought I would share.

All the best
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #4 ·
Thanks for the reply guys! I'll have to take a thorough investigation of this half-assed tail assembly job this weekend. I did take off the side fairings and the small plastic piece last weekend and didn't notice anything weird except for the fact that the small plastic piece looked like it needed to fit under the metal bracket it was sitting on top of. I tried moving it below it but ran into issues with fitment on the little small flare pieces on the under tail assembly. :dontknow: I will have to take it apart fully and do some digging like you mentioned SkyDork
 

·
The Pace
Joined
·
7,163 Posts
Do both the running and brake lights work. If so, I would simply ride the bike; no worries, be happy.

And what year is that?
 
1 - 6 of 6 Posts
Top