Kawasaki ZX-10R Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
128 Posts
Discussion Starter #1
I've had a quick look and have some questions. Looks like no temp sensor ????. No connections for both butterfly sensors on right side of throttle body. I have a connector that has tps written on it next to the earth wires with no tps any where near the plug. I'm sure someone has been here before and some advice may save me a lot of time.
Also do I need to buy a new fuel pump relay or can I use something from the original loom. Thanks in advance gum .
 

·
Registered
Joined
·
2,164 Posts
You'll need to buy the relay, I got mine for $30 from Superbike toy store.

Installing the harness was very straight foreward. I installed the plastic rivet that's attached to the harness in the same position the oem one was and worked my way backwards then forewards. You will have connections for both butterflies and a tps sensor. They look identical to the ones that were removed from the oem harness.

Which side of the bike did you run the harness down?
 

·
Registered
Joined
·
128 Posts
Discussion Starter #3
I have laid it on the right side it's late here. Just had a quick look at it and posted the question. Thanks
 

·
Registered
Joined
·
128 Posts
Discussion Starter #5
Nope. With fresh eyes this morning. No temp sensor connector. No connectors for the the butterflys on the far right side. I have a plug near the top of shock six pin square connector using five pins. It has tps on it written by someone have no where to plug that. I've checked the part number. 26031-1219 so it should fit. I can't find any decent instructions on this. Gum
 

·
Registered
Joined
·
128 Posts
Discussion Starter #11
I have studied the pics of the loom on the net. None have a temp sensor or the sensor s on the right side of the throttle body.
 

·
Registered
Joined
·
128 Posts
Discussion Starter #12
Fixed. My bad. I had a big off the hay shed at Phillip island six month ago. Bike was pulled apart at that time. It had a bazzaz which I tried to sell. Lucky for me it didn't. There is one jumper wire on the original loom that needs to be retained. It jumps both tps and the temp sensor. Fuck thought I was going insane. Thanks for the input. Gum

Yep it was still on the bazzaz. Phew
 

·
Registered
Joined
·
128 Posts
Discussion Starter #13
Quick shifter. Looks like two options. I take it I solder into the blue connector. I'm using the dynojet
 

·
Registered
Joined
·
343 Posts
I saw this thread too late, but you figured it out, the race harness does retain some of the original wiring such as the butterfly leads and TPS.

The spare connector that you have on the left of the engine was from your side stand switch. It remains spare, just heat shrink and wrap it up to keep it clean and out of the way.
 

·
Registered
Joined
·
128 Posts
Discussion Starter #18
What can I expect off the bat with this ecu. Have dialed the cams. Decked the head. Air cleaner exhaust etc etc as per the race manual. Fitted the dyno jet shifter. I take it the tune will be good. Traction control will work as before and the quick shifter will also work. Will it still have power maps and the three settings for the traction control. I'm loathed to get it dynoed as someone who is not familiar with it may make it worse. Any thoughts.
Gum
 

·
Registered
Joined
·
2,060 Posts
Some may call it heresy, but I'm using a PC-V on top of the kit ECU for the fueling. With that option, you get a faster processor with higher cell resolution, and the ability for any quality Dynojet tuner to give you a great fueling map.

The kit ECU still provides quickshifter, ignition, engine braking, and traction-control settings, while the PC-V provides the fueling. Works like a champ for me after having it dyno-tuned by a guy I trust.

My guess is you'll be hard pressed to find anyone out there who has a clue about adjusting the kit ECU fueling and the ability to dyno-tune a quality map for you. But there's lots of guys out there who can tune a PC-V.

And yes, you'll still have three power and three traction-control settings to select.
 

·
Registered
Joined
·
128 Posts
Discussion Starter #20
Great. Just one last one. Is the quick shifter activated and just plug it in and away I go.
Gum
 
1 - 20 of 21 Posts
Top