Kawasaki ZX-10R Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1,483 Posts
Discussion Starter #1
Anyone install a race ECU? The 'used twice' unit I just bought off ebay doesn't power the fuel pump. This isn't some strange thing I have to program, by chance?

I don't have the programming cable yet, but this one was supposedly loaded with a map.

Thanks,
Dean
 

·
Registered
Joined
·
1,483 Posts
Discussion Starter #3
Yeah, I could do that, but I don't know if this is the only problem with the ECU. Maybe the whole thing is toast, huh?
 

·
Registered
Joined
·
1,483 Posts
Discussion Starter #5
I think I need the adapter harness 26031-0427 to use a kit ECU with the stock wiring harness. KHI expects that the kit ECU will be used with the race harness, so some pins may be diff. My programming cable and adapter harness (which I thought was for the prog cable) are on the way. Whew.
 

·
Registered
Joined
·
1,561 Posts
I think I need the adapter harness 26031-0427 to use a kit ECU with the stock wiring harness. KHI expects that the kit ECU will be used with the race harness, so some pins may be diff. My programming cable and adapter harness (which I thought was for the prog cable) are on the way. Whew.
dsabat, what do you have all said and done into making that kit work. like $1300?
 

·
Registered
Joined
·
1,483 Posts
Discussion Starter #7
To buy new, $1200. Because of the deal on the ECU, I'll end up paying about $750.
 

·
Registered
Joined
·
475 Posts
i think my problem is that i have an 04 and im trying to usr an 05 kit ecu.i also tried it with the harness adapter.whats the part number on your kit ecu?
 
1 - 9 of 9 Posts
Top