Kawasaki ZX-10R Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
546 Posts
Discussion Starter #1
Just installed my PCV last week.. And did the spark plugs while I was there. This weekend was the first weekend I really had a chance to get some lengthy riding in. After riding for a while the bike looses power and it sounds like a dam Ducati. I think it is running lean. When it does it I cycle the key off and then start it and the issue is gone, but after riding for a little bit it will do it again.. At first I thought mabey the fuel line was pinched and it was intermittently starving for fuel but the fuel line looks fine. I was running a map that GSP gave me (me and his bike have almost identical mods), but the map he gave me was optimized w autotune so I thought mabey that had something to do with it. So I changed to a base map and it still did it.. Think im gonna take the PC out and try to run it again and then I will know for sure.. Was wondering if any of you have had this happen?:dontknow:

It is a 2012 with wire mod, k and n, m4gp slip on with baffle taken out, 16t in the front. The bike ran like a top before the PCV and plugs were installed, and runs great with the PCV when its not fucking up. Pretty sure the problem isnt with the plugs because cycling the key wouldnt do much to remedie an issue with plugs.
 

·
Registered
Joined
·
1,357 Posts
Just talked to tech support, they said try updating the firmware like 3 times,, they said sometimes it doesnt install all the right drivers.
:rolleyes:
Are you running win 7 on pc? if XP then it is problematic for the correct drivers and flash. Since you did plugs, I would disconnect all PCV connectors and ride to see what happens.
 

·
Registered
Joined
·
76 Posts
I had the same problem with my PCV. The bike stalled on me in heavy traffic while doing 80 on the interstate. The shoulder was 3 lanes over and I had to cut cars off without the inability to turn the bike back on.

It's an intermittent dropped cylinder issue. Send the unit back and have it replaced. I bought a second unit and DJ overnighted it to me. I sent the defective unit and received a refund. They have great customer service and will help you out as much as they can.


Sent from my iPhone using Motorcycle.com App
 

·
Registered
Joined
·
546 Posts
Discussion Starter #9
Are you running win 7 on pc? if XP then it is problematic for the correct drivers and flash. Since you did plugs, I would disconnect all PCV connectors and ride to see what happens.
Win 7.. I did update the firmware when I first got it, and I did verify that there is an update in the new ware that is supposed to address a "droped cylinder issue" I called and they asked how many times I installed the new firmware, I said 1, They said sometimes ya have to do it like 3 times. :dontknow: So I updated it 4 times last night and reinstalled the map ya gave me.. hoping we get some half decent weather this weekend so I can go test her out...
 

·
Registered
Joined
·
546 Posts
Discussion Starter #10
I had the same problem with my PCV. The bike stalled on me in heavy traffic while doing 80 on the interstate. The shoulder was 3 lanes over and I had to cut cars off without the inability to turn the bike back on.

It's an intermittent dropped cylinder issue. Send the unit back and have it replaced. I bought a second unit and DJ overnighted it to me. I sent the defective unit and received a refund. They have great customer service and will help you out as much as they can.


Sent from my iPhone using Motorcycle.com App
That had to be scary.......
 

·
Registered
Joined
·
2,726 Posts
have you tried unplugging the power commander and riding it to make sure it is the pc5? also, find a dyno tuner and have em put a custom map in that thing, your bike desperately needs it
 

·
Registered
Joined
·
546 Posts
Discussion Starter #12 (Edited)
have you tried unplugging the power commander and riding it to make sure it is the pc5? also, find a dyno tuner and have em put a custom map in that thing, your bike desperately needs it
I have a buddie that does tuning , just waiting for him to get some free time to tune her for me.... and unplugging the pcv on the gen 4 is basically uninstalling the whole thing.. has like a dozen plugs on it. lol. Deff havent tried that yet.. hoping this installing the firmware again does the trick.. If not uninstalling it is the next step.
 

·
Registered
Joined
·
546 Posts
Discussion Starter #13

·
Registered
Joined
·
4 Posts
Same shit happened to me, I am trying to get a new one atm. I might get a refund and try something else like a bazzaz or just a ECU re-flash. Not sure how comfortable i feel with PC after losing power when i was trying to pass a car on the freeway.
 

·
Registered
Joined
·
546 Posts
Discussion Starter #15
Same shit happened to me, I am trying to get a new one atm. I might get a refund and try something else like a bazzaz or just a ECU re-flash. Not sure how comfortable i feel with PC after losing power when i was trying to pass a car on the freeway.
Happened to me mid wheelie.. Talk about scary. lol
 

·
Registered
Joined
·
76 Posts
Happened to me mid wheelie.. Talk about scary. lol
Was there a stain in the inside of your pants? I couldn't imagine having a power loss out of nowhere.

Come to think of it, this only happened when I was accelerating really hard.

As for updating the firmware... It will show you that the firmware update is done regardless of if it does or not. Every time I tried to update my unit I would see an error on line 19 of the update. Make sure click the progress button and scan it to see if anything shows an error.

If it doesn't show an error then go online and let DJ diagnose it for you. When you bought the unit you also paid or their customer support. If they can't do it online they will then give you a return authorization number.


Sent from my iPhone using Motorcycle.com App
 

·
Registered
Joined
·
546 Posts
Discussion Starter #17 (Edited)
Was there a stain in the inside of your pants? I couldn't imagine having a power loss out of nowhere.

Come to think of it, this only happened when I was accelerating really hard.

As for updating the firmware... It will show you that the firmware update is done regardless of if it does or not. Every time I tried to update my unit I would see an error on line 19 of the update. Make sure click the progress button and scan it to see if anything shows an error.

If it doesn't show an error then go online and let DJ diagnose it for you. When you bought the unit you also paid or their customer support. If they can't do it online they will then give you a return authorization number.


Sent from my iPhone using Motorcycle.com App
Ya I was a little scared.. One min you have the wheel in the air next min you sound like a ducatti and the front end comes crashing down. lol.. Not a good time. and I actually had it happen just cruising at low rpm and under hard accel..

The guy at dj said the same thing and he said update it like 3 times in a row so for good measure I did it 4 times.. hoping to get some good weather so I can test her out.. trying to get her tuned in the next few weeks and dont wanna send it out for a tune with a fucked up pc
 
1 - 17 of 17 Posts
Top