Kawasaki ZX-10R Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
241 Posts
Discussion Starter · #1 ·
cant figure out how to get my codes to come up on the display i have no wire to ground and she wont start i changed the battery tested the kickstart switch tried pushstarting emptied gas , put new fuel pump and it still doesnt want to fire. cant figure out how to get to the spark plugs i get the air box off but cant get it out of this damn frame anyone with an 07 ninja zx10r se want to let me in on the self diagnostic secret made easy?
 

·
Banned
Joined
·
15 Posts
Had the same problem 5 years back on my 600. Tried everything and nothing worked!! Spent $$$ trying plugs battery and so on. Went to the local bike shop paid $65 and they had her running in an hour. Sometimes you got to go to the pros!!! Good luck though!!!
 

·
Registered
Joined
·
658 Posts
ps im in austin texas if anyone lives close
there should be plenty of fellas in Texas that live near you, go to regional section on this forum and Im pretty sure that I saw a threat about Austin, Texas, and try contacting some guys from there
 

·
Registered
Joined
·
445 Posts
after you take the bolts out of the air box stand on the kickstand side of the bike, grab the airbox with both hands, and rotate it clockwise while sliding it back toward the rear of the bike. It will rotate right out of the frame. The spark plugs are about 5" deep in the head and you will have to remove the stick coils to get to them. Be careful not to damage the coils as they can be tough to remove. Honestly I dont think it is the plugs if it is not hitting at all. either you are not getting fuel on not getting spark. Need to check the current @ the leads to the stick coils and check and see if you have the right fuel pressure. You can get a kawi service manual for about $75 that will cover just about anything you might want to do mechanically to your bike.
 

·
Registered
Joined
·
319 Posts
As crazy as it might sound!!!!!, try a new ignition switch. I had the same problem with an 01 ZX-7R.
 

·
Registered
Joined
·
121 Posts
cant figure out how to get my codes to come up on the display i have no wire to ground and she wont start i changed the battery tested the kickstart switch tried pushstarting emptied gas , put new fuel pump and it still doesnt want to fire. cant figure out how to get to the spark plugs i get the air box off but cant get it out of this damn frame anyone with an 07 ninja zx10r se want to let me in on the self diagnostic secret made easy?
To get the spark plugs out you have to take off the side fairings and the fairing brackets. Believe me when I say clear your schedule for that day.
 

·
Registered
Joined
·
1,276 Posts
Didnt I read that you have a new ignition switch with 7 wires..and yours only had, 5 was it?

What is the bike doing? Cranking and not starting? Not cranking?

Best bet would be to take it to the dealer I think. I'd mess with it for ya but I'm in Dallas.

**EDIT**
okay..

http://www.zx-10r.net/forum/search.php?searchid=2002702

all your threads. So new battery, new zx6 pump (did you put your 10r one back in?)

any blown fuses?

From what I read the bike is cranking but will not start. You are NOT hearing the fuel pump prime. I Would check fuses.

Did you get the correct ignition switch for the bike? THere was a part # listed.
 

·
Registered
Joined
·
241 Posts
Discussion Starter · #11 ·
thx

:crackup:yes it turns over but doesnt want to fire i took the 7 plug ignition completely off since it had no chance at workign and tried hotwiring her i got the porwer and all accessories on and its ready to start its just not firing im in the process of trying to buy a new ignition that will work but until then id like to be at heatwave rollling with my boys thanks for all your ideas i think im going to get the switch and install that asap i already got the maual and have tried several things but i cant seem tofigure out how to get the codes so possibly i could just narrow uit down does the new ignition have to be coded? i saw that in the manual butttt the guy at the stealership said it didnt its plug and play when i get the correct ignition
 

·
Registered
Joined
·
2,616 Posts
ps im in austin texas if anyone lives close
What up DJR! I'm in N. Austin and might be able to help ya! That airbox can be tricky, but once you figure it out it's cake. I'm free all weekend(unless my new parts come in) and am more then willing to help. Just send me a pm or call me at 698-4157.
 

·
Registered
Joined
·
241 Posts
Discussion Starter · #13 ·
tight im in round rock plus i can always use a riding buddy i only have one well not like i have been riding anywhere lately
 

·
Registered
Joined
·
2,616 Posts
I'm down to ride as long as it's in the morning or after dark. I usually hit up the twisties on SUnday morning, but I've been looking for people that would be interested in just cruising on a Sat. night. I'm currently waiting on a stator cover and footpeg before I can get back on the road, so I've been caging it in the A/C!
 

·
Registered
Joined
·
241 Posts
Discussion Starter · #15 ·
yeah thats tight all i need to the trouble shoot which im told will be fixed with a new ignition switch and key but im not sure if i am going to have to get the key coded or if its plug and play ? and a new rear brake bracket and then im dandy ive been in my prelude enjoying the a/c also i got to say its a definite perk what part of austin you live in pf?
 

·
Registered
Joined
·
1,276 Posts
in the US we don't have the immobilizer system. The new switch should come with a new key...I'd think. You'd have to get your key cylinder for the "trunk" re-keyed.
 

·
Registered
Joined
·
2,616 Posts
yeah thats tight all i need to the trouble shoot which im told will be fixed with a new ignition switch and key but im not sure if i am going to have to get the key coded or if its plug and play ? and a new rear brake bracket and then im dandy ive been in my prelude enjoying the a/c also i got to say its a definite perk what part of austin you live in pf?
Parmer and Metric. Did you get that airbox out?
 
1 - 18 of 18 Posts
Top