Kawasaki ZX-10R Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hi there,
I have this problem with my oil pressure light!
Sometimes it start to blink/burn when my bike is running on idle and always when the engine is hot.
And when i just live a little bit more gas over approx 1100 rpm it`s going out.:dontknow:
Sometimes i a can make a ride from 150 miles and nothing happens, somethimes in 150 miles it goes on several times, but always when the engine is on idle!!!!
I changed the oil pressure switch, oil,and filter(original)
Is there anyone who recognises this problem?
Greetings from a cold and windy Holland
 

·
Registered
Joined
·
753 Posts
Well.. Greetings to you from the country where Maxima was born :hello:

For some reason you have low oil preassure in your engine.
It would be usefull to know how many kms is showing the odo.
Also what kind of oil do you use (sae)
The oil pump mesh might be clogged if a serious clutch problem has happend in the past.

Let us know
Pablo
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
Hello Pablo,

Now that it is so cold and windy in Holland, Maxima might get homesick to Argentina.
But she is very popular here in our cold, small,wet,windy, Holland!

Thanks for your reply.
27000 kms, big check up at 24000 kms, then started the problem.
My dealer doesn`t understand it either, but we are are still searching for the problem together.(he is also a good friend of me, so no extra charges)
use 10w40 semi syntethic from the first km.
Never had a clutch problem.
Keep on replying!
Maybe someone else an idea :idea:
Greetings
Theo
 

·
Registered
Joined
·
753 Posts
Hello Pablo,

Now that it is so cold and windy in Holland, Maxima might get homesick to Argentina.
But she is very popular here in our cold, small,wet,windy, Holland!
Theo
jaja...well.. I´m pretty sure there´s plenty of people keeping Maxima safe away from cold:lol:

I think checking the oil pressure is a good start point, if you haven´t done this yet.
If pressure shows low, then the oil pressure relief valve has to be checked.
Here are the service pages:
 

Attachments

·
Registered
Joined
·
363 Posts
I don't know what the stock oil pressure switch is set to turn on at, but we see this normally after a session when the oil is hot, over 200 degrees (which is no problem). The oil thins out a bit. If you ever see the light come on at anything other than idle then you have a serious problem. You probably have 5-10 PSI when the oil is hot. I use redline 40wt full synthetic racing oil.

If you want to reassure yourself that all is well, definitely hook up a test port to the oil gallery where the above pages show. Thats where we monitor the pressure. Ride a while to get the oil good and hot, and check the gauge when at speed (if possible) and again at idle. If you have an IR gun, check the oil temp in the pan to determine the temp). We use a separate oil pressure switch set to about 15 PSI, and the light will turn on when idling around in the pits.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #6
jaja...well.. I´m pretty sure there´s plenty of people keeping Maxima safe away from cold:lol:

I think checking the oil pressure is a good start point, if you haven´t done this yet.
If pressure shows low, then the oil pressure relief valve has to be checked.
Here are the service pages:
Thanks for pages anyway, my dealer and myself also looked into the manual and we also thought that the oil pressure relief valve might be the problem.
We didn`t open the engine yet because we want to be 99% sure that`s the problem.
It`s quit a job.
Whem i see Maxima for lunch, i will tell her that a friend from Argentina try`s to help me.:lol: :lol: :lol:
 

·
Registered
Joined
·
12 Posts
Discussion Starter #7
I don't know what the stock oil pressure switch is set to turn on at, but we see this normally after a session when the oil is hot, over 200 degrees (which is no problem). The oil thins out a bit. If you ever see the light come on at anything other than idle then you have a serious problem. You probably have 5-10 PSI when the oil is hot. I use redline 40wt full synthetic racing oil.

If you want to reassure yourself that all is well, definitely hook up a test port to the oil gallery where the above pages show. Thats where we monitor the pressure. Ride a while to get the oil good and hot, and check the gauge when at speed (if possible) and again at idle. If you have an IR gun, check the oil temp in the pan to determine the temp). We use a separate oil pressure switch set to about 15 PSI, and the light will turn on when idling around in the pits.
Thans for the reply,
The light only goes sometimes on at idle, nothing else!
So we probally have to messure the oil pressure.
But that will happen in the spring, because Holland is small, cold, wet windy country in authum.
 
1 - 8 of 8 Posts
Top