Kawasaki ZX-10R Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
727 Posts
Discussion Starter #1
I just changed my oil getting all ready to go for the summer. and since i changed it the oil light came on. Its not leaking oil and the level is right in the middle of the sight glass. changed oil a bunch of times and never had this happen. alrady double and tripple checked everything. filter is tight not leaking and not leaking from the drain bold and the fill cap is on tight. anything else to check or has anyone had this problem before? or know what could be going on?
 

·
The Pace
Joined
·
6,903 Posts
On my g4 dang oil light came on every day for like 3 weeks. I never change the oil, but someone told me to fill it up. I did, but light still came on. Bike ran like all perfect, so I never paid any attention to it, just would notice it when it came on. It would light up somewhere on the loop, but usually when it was working hard, as in high rpms.

When I stopped to fill up at the end of the loop, and restarted, light would always be OFF, and stayed off the final half mile home.

OK, well about two weeks ago, the red light STOPPED coming on. Been on it about every day, too.
 

·
Registered
Joined
·
727 Posts
Discussion Starter #6
thanks guys, and magma. ill try to burp it tomorrow. i filled the filter about as much as i could when puttiing it on without getting oil everywhere. the filter is the kawa fikter from the dealer. havent switched to synthetic yet so just stuck with the kawa bran filter. appreciate the help guys!
 

·
Bloo Moderator
Joined
·
23,742 Posts
thanks guys, and magma. ill try to burp it tomorrow. i filled the filter about as much as i could when puttiing it on without getting oil everywhere. the filter is the kawa fikter from the dealer. havent switched to synthetic yet so just stuck with the kawa bran filter. appreciate the help guys!
Another thing to check is the Oil Sensor maybe OIL is stuck in there or you washed your bike with a hose but under the Rubber grommet it could cause a false reading for your oil resistance light to come on, the reason I mention this is because you did fill your oil filter first shouldn't be a problem so check it out if the burping doesn't help.


Bloo
 

·
Registered
Joined
·
371 Posts
Theres a sticky or something here on changing the oil. Try a search. The sequence was change and refill the oil. Then change the filter. Or filter first, then oil.

Goal is not to have both sides empty at one time.

That said, I did an oil change on the 06 Sat, had the procedure printed out by the bike, and forgot. Light came on. I loosened the filter and let it drip some. Tightened and restarted and she's fine.
 

·
Registered
Joined
·
727 Posts
Discussion Starter #9
thanks a lot guys. loosened the filter and nothing came out so i pulled it all the way off. filled the filter and started jt. light was on for about 5 seconds then went off so it worked. i appreciate all the help!
 

·
Registered
Joined
·
2,034 Posts
On my g4 dang oil light came on every day for like 3 weeks. I never change the oil, but someone told me to fill it up. I did, but light still came on. Bike ran like all perfect, so I never paid any attention to it, just would notice it when it came on. It would light up somewhere on the loop, but usually when it was working hard, as in high rpms.

When I stopped to fill up at the end of the loop, and restarted, light would always be OFF, and stayed off the final half mile home.

OK, well about two weeks ago, the red light STOPPED coming on. Been on it about every day, too.
Dude, you burned that light clean fookin out! lol
 
1 - 12 of 12 Posts
Top