Kawasaki ZX-10R Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter · #1 ·
:hello:

Thought I'd introduce myself, as I've been lurking for a bit....I finally opted to register, and here I am!

I purchased a brand new '08 10r in black back a few months ago, and have definitely enjoyed it thus far (Just over 3k miles now:) ). This is not my first bike by any means, but it is definitely in a league of it's own. I purchased a brand spankin new 6r back on 1998 (OMG has it been that long!) as I've always been a Kawi guy.

Anyways, I'm glad I found a good source for info and discussion! Hopefully I can shed some light on the subjects I'm most familiar with (turbo related, Automotive, Warrany Admin., etc.)
 

·
Guilty by association
Joined
·
8,752 Posts
welcome to the site!
 

·
Blitzkrieg
Joined
·
4,473 Posts
:welcome:
 

·
Registered
Joined
·
41 Posts
Discussion Starter · #11 ·
I know this is not really the right spot to ask, and searching has given me some insight, but nothing fitting my exact symptoms, so riddle me this, if you can:

I get a nice squeak from the rear brake at about 15 mph. I've looked into a number of other threads, and checked a number of things. I noticed that when I get home if I blow out the dust with air, I won't get the squeak for a bit on the next ride. It only happens with a light input, and sounds a lot like ceramic pads on a performance car. Albeit not nearly as loud. Rotor is square, and having disassembled both front and rear brakes (for the hell of it, I guess) I have no idea, other than maybe the OEM pad material.....Any thoughts?
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top