Kawasaki ZX-10R Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
226 Posts
Discussion Starter #1
I've seen this issue here before but could not find it > My new zx10r 2009 steers to the right when i let go of the steering . I have had many bike before this one and never got that before , always ran straight . Anybody have a solution ?
At first i thought it maybe the crown of the road but even it i ride completely to the left hand side of the road is still goes right !
 

·
Registered
Joined
·
1,836 Posts
Some people changed the spacers in the tire and had great success with that. Some claim that changing the stock exhaust helped or aligning the rear tire. My 3rd gen fortunately don't suffer from this.
 

·
Registered
Joined
·
380 Posts
I've seen this issue here before but could not find it > My new zx10r 2009 steers to the right when i let go of the steering . I have had many bike before this one and never got that before , always ran straight . Anybody have a solution ?
At first i thought it maybe the crown of the road but even it i ride completely to the left hand side of the road is still goes right !
You can try what was said above, none of it worked for me. It doesnt pull as bad as it used to, but still does none the less, I just learned to live with it.
 

·
Registered
Joined
·
1,130 Posts
Check your rear wheel and make sure its aligned evenly on the swing arm ...
 

·
Registered
Joined
·
2,143 Posts
my bike is brand NEW . It's done this since i left the dealer and i now only have 600 miles .
Take it back to the dealer and have one of their techs ride it. They will take care of the issue. My 08 didn't have this problem but I had a buzzing in the front (a minor little buzzing that most wouldn't even notice) and they took care of it. Dude, its a new bike trust me... they'll make it right:thumbsup:
 

·
Registered
Joined
·
412 Posts
Mine did this and I had to move the right side of the tire up one notch on the swingarm. Perfect alignment now. I know that's odd as hell. I'm almost sure its the triple though. Just off setting it with the rear tire. I never wheelie so it doesn't matter much.

That or the swingarm is messed up.
 

·
Registered
Joined
·
134 Posts
If I recall correctly we had one guy on this forum that found out he had a bad new tire creating the pull to one side, so keep that in mind as a possibility.
 

·
Registered
Joined
·
534 Posts
mine pulled too, I realigned the rear tire using a tape measure to measure from the front of the rear set to the middle of the axle on both sides and it no longer pulls. DO NOT USE THE HASH MARKS ON THE ADJUSTMENT BLOCKS, THEY ARE NOT PROPERLY LINED UP (they have NEVER been lined up on ANY bike I have ever worked on)
 

·
Registered
Joined
·
242 Posts
if those solutions stated above do not work, check your steering head bearing (could be over tightened) or even just check the tire pressures. its definitely something small and insignificant.
 

·
Registered
Joined
·
226 Posts
Discussion Starter #13
i figured it was a rear wheel alignment problem but i didn't want to deal with it until i got some response from you guys . I am sure if i leave it as it will cause some negative impact on the tires . I feel as if the bike is out of balance and i just don't feel right on it . I'll have to go in for my 1st inspecting this week and ill ask them to check on it . I'll post an update in a few days .
 

·
Registered
Joined
·
380 Posts
Mine did this and I had to move the right side of the tire up one notch on the swingarm. Perfect alignment now. I know that's odd as hell. I'm almost sure its the triple though. Just off setting it with the rear tire. I never wheelie so it doesn't matter much.

That or the swingarm is messed up.
Perfect Alignment as in it rides straight or as in the tire is now on straight??? I thought about trying this just havent gotten around to it.
 

·
Registered
Joined
·
1,688 Posts
I've seen this issue here before but could not find it > My new zx10r 2009 steers to the right when i let go of the steering . I have had many bike before this one and never got that before , always ran straight . Anybody have a solution ?
At first i thought it maybe the crown of the road but even it i ride completely to the left hand side of the road is still goes right !
Good Luck. I've tried everything.

Mines better now, but not like it should be.
 

·
Registered
Joined
·
1,246 Posts
Ohlins forks cured it for me lol:crackup:
 

·
Registered
Joined
·
412 Posts
mine pulled too, I realigned the rear tire using a tape measure to measure from the front of the rear set to the middle of the axle on both sides and it no longer pulls. DO NOT USE THE HASH MARKS ON THE ADJUSTMENT BLOCKS, THEY ARE NOT PROPERLY LINED UP (they have NEVER been lined up on ANY bike I have ever worked on)
BINGO...i am convinced of this as well now. for one thing the damn swingarm is drawn in when you tighten it. at least mine is. this alone will throw off the "notch" marks. who designed this shit?
 
1 - 19 of 19 Posts
Top