Kawasaki ZX-10R Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
256 Posts
Discussion Starter · #1 ·
So i removed the intake flap N related junk plug the hose going to throttle bodies i believe. Also replaced my starter as well got everything buttoned up nice and tight go for a ride all fine and good. Try to step out past 8k bike just sits at 8k nothing past. I pull over check clutch cables give a lil slacc. Go bk out bike is fine wont rev pass 10k. Pull into gas station lil smoke from under the tank. So i push her home. I was thinking the smoke was from spilling fuel a little earlier. Double checcd Everything pull the thop of the airbox off start the bike throttle body blades dont move on start up whwn i shut it off they open fully was told stva but how.. Any help appreciated thanks time is def against me as well.
 

·
REPOST Enforcement Mod
'16 ZX-10R KRT
Joined
·
15,727 Posts
Why are you checking the clutch cable slack if the motor won't rev past 8,000rpm?

The typical reason that happens is from a pinched fuel line when putting the tank back down and into position. You have a kinked or pinched fuel line that is starving the motor for fuel when the upper injectors are trying to open.
 

·
Registered
Joined
·
256 Posts
Discussion Starter · #3 ·
Why are you checking the clutch cable slack if the motor won't rev past 8,000rpm?

The typical reason that happens is from a pinched fuel line when putting the tank back down and into position. You have a kinked or pinched fuel line that is starving the motor for fuel when the upper injectors are trying to open.
Went over everything i had touched. You were right pinched line, thank you
 
1 - 3 of 3 Posts
Top