Kawasaki ZX-10R Forum banner

1 - 20 of 65 Posts

·
Registered
Joined
·
191 Posts
Discussion Starter #1
Hey guys, i have a 07 zx10r..bought used, my 2nd zx10. had 6000miles on it when i picked her up. Never had any problems the past 2 months or so since i have owned her. Well i had the barracuda gp style slip on exahust on it, and also a power commander..sounded great but didnt dig the sound, so i sold it like a week or so ago to a member on here. I think it has a custom map, but not sure, i just know the bike has smooth powerband, no issues, idles great, and no misfires. Which is why i assumed it was custom tuned..Well after i unbolted the barracuda, i did a short ride with no exhaust( i know some people say dont do it no back pressure) but it was a short ride. when i started riding her, i noticed the bikes rpms were jumping...like idling like some a corvette with some bad ass cams...but only when im riding. Not when just idling. Its yanking gently when cruising..i noticed this only when i had the no exhaust..so today i installed the factory exhaust...expecting it to fix the issue...it didnt. same problem. does anybody have any clue what it could be? id rather ask you guys then go spend over 100 bucks just to get a dealer to check it out...
 

·
Registered
Joined
·
191 Posts
Discussion Starter #3
yea i just sold it like a week and half ago. But ive only rode twice since i sold it, once without exhaust and thats the first time it started, and then today, after i installed the factory exahust..
 

·
Registered
Joined
·
8 Posts
hey bro what else aside from the pc and exhaust is done to the bike? i go to school for motorcycle mechanics so i'll see if i can help you out? describe in more detail how long you went for a ride and what you were doing while riding? lets see if we cant get to the bottom of this. if you have any more questions hit me up.
 

·
Registered
Joined
·
191 Posts
Discussion Starter #11
no it doesnt spike or slip...it like goes back and fourth back and forth..i guess after i figure how ima mount my helmet cam ill take a video...If you ever heard a big cammed car idle, whomp whomp whomp whomp whomp, and the rpms fluctuating to make that sound, thats what this does, but NOT at idle. so when im cruisn. lets say 3rd gear 4000rpms...the bike is going whomp whomp whomp whomp and the rpms would be going from 3800-4200 while riding down the street, and while it goes whomp whomp whomp the bike is literally pulling and slowing down, pulling and slowing down..
 

·
All show and all go 10r
Joined
·
5,921 Posts
Fuel filter the thing that removes the crap out of the fuel before it enters the fuel rail. Probably not it after what you said but still worth a look.
 

·
Registered
Joined
·
191 Posts
Discussion Starter #13
Fuel filter the thing that removes the crap out of the fuel before it enters the fuel rail. Probably not it after what you said but still worth a look.
well i understand what it is, but what i was asking is what would that have to do with my problem? i just wanted your opinion on why you thought that was it.. thanks
 

·
Registered
Joined
·
8 Posts
you said that this started happening after you took off the exhaust and rode it a couple of times? or after you took off the power commander? how many miles are on the bike? have you tried putting the old exhaust back on or did you sell it or something? i have some more questions but answer these and well see where it leads us cuz i have a few ideas of what it could be
 

·
Registered
Joined
·
8 Posts
hey if anyone has any 04-05 zx10r parts or knows anyone who does let me know looking for a motor 04-05? any parts or the whole motor let me know thanks!?
 

·
Registered
Joined
·
191 Posts
Discussion Starter #18
you said that this started happening after you took off the exhaust and rode it a couple of times? or after you took off the power commander? how many miles are on the bike? have you tried putting the old exhaust back on or did you sell it or something? i have some more questions but answer these and well see where it leads us cuz i have a few ideas of what it could be
I never removed the power commander, right at 7000 miles i think. and like i posted before, i sold the exhaust that came on it, and put the stock exhaust on today..

thanks for the help/interest so far guys..
 

·
Registered
Joined
·
8 Posts
if you didnt replace your exhaust gasket you could have an exhaust gasket leak. cause even through you can reuse if your not careful with torqueing down the exhaust nuts you can mess up the gasket.
 

·
Registered
Joined
·
191 Posts
Discussion Starter #20
if you didnt replace your exhaust gasket you could have an exhaust gasket leak. cause even through you can reuse if your not careful with torqueing down the exhaust nuts you can mess up the gasket.
good thought, but now it...i did not take the header off or the cat, just the slip on, and even if there was a leak i dont think it was cause my bike to be pulling back and fourth while riding...ill need to post a video showing how bad it does it so you guys get a better idea.
 
1 - 20 of 65 Posts
Top