Kawasaki ZX-10R Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
173 Posts
Discussion Starter #1
so when i turn it on it idles and keeps randomly knocking and the rpms spike about 200 each time that happens. any idea what could be wrong with it? no engine light.
 

·
Registered
Joined
·
328 Posts
Valve cover wouldn't have anything to do with fuel in oil. Most likely a head gasket.

Sent from my LG-MS910 using Motorcycle.com Free App
 

·
Registered
Joined
·
173 Posts
Discussion Starter #5 (Edited)

changed the oil just before the video and it doesn't seem to have fuel in it, must have been my imagination.

ha i kicked one of my empty beer bottles at the end XD. got pissed off by the unusual idle and started drinking.
 

·
Gen2 Ripper
Joined
·
4,867 Posts
Make sure the coil caps are aligned properly. They are lines on top of cap and on valve cover. Sounds like it is mis firing and dumping fuel.
 

·
Registered
Joined
·
173 Posts
Discussion Starter #7
it might be the spark plugs, the service manual fails to mention that you must screw in the coil plug not push it down. i pushed them down which strip the threading on the top of the spark plugs. going to the store now to buy new ones to see if it fixes it.
 

·
Registered
Joined
·
173 Posts
Discussion Starter #9
cleaned the throttle body with 99% isopropyl alcohol, replaced the spark plugs and cleaned out the coil packs with 99% isopropyl alcohol. installed them at the correct angle and it seems to be running correctly now.
 
1 - 9 of 9 Posts
Top