Kawasaki ZX-10R Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
147 Posts
Discussion Starter #1
So- I have my hybrid 2011+ ZX10 with a Kit Harness where I cannot find any plug ins for the Throttlebodies or coolant temp sensor, along with a few other minor issues. Everything is brand new, has anyone installed one yet? I have the kit manual but nothing in there about this. Hence, I cannot start the thing.
 

·
Registered
Joined
·
147 Posts
Discussion Starter #3
thats what i am trying to find out, for sure there is not kit parts i am missing tho, and its never been a streetbike so there are zero stock parts on the bike...
 

·
Registered
Joined
·
581 Posts
Which plug-ins on the throttle bodies are you referring to? Secondary motor, TPS sensors? Those should all definitely have connectors on the harness somewhere. There is also definitely a coolant sensor plug on the harness as well. Assuming you have the correct harness, the plugs are on that harness somewhere. You should be able to fully install the kit ECU with just the kit harness and the fuel pump relay. The kit manual has a wiring diagram in it that tells you the color of the wires going to each plug which should help in narrowing down which plug goes where. Just go through each left-over plug until you find the one you need for each connection. There will be a few left over plugs in the end though for the interface box, quick-shifter, etc.

How long did it take to get your ECU & Harness after you ordered them? I'm waiting on back-order from Kawasaki for my harness, so I haven't got the chance to install it yet actually...
 

·
Registered
Joined
·
147 Posts
Discussion Starter #5
Which plug-ins on the throttle bodies are you referring to? Secondary motor, TPS sensors? Those should all definitely have connectors on the harness somewhere. There is also definitely a coolant sensor plug on the harness as well. Assuming you have the correct harness, the plugs are on that harness somewhere. You should be able to fully install the kit ECU with just the kit harness and the fuel pump relay. The kit manual has a wiring diagram in it that tells you the color of the wires going to each plug which should help in narrowing down which plug goes where. Just go through each left-over plug until you find the one you need for each connection. There will be a few left over plugs in the end though for the interface box, quick-shifter, etc.

How long did it take to get your ECU & Harness after you ordered them? I'm waiting on back-order from Kawasaki for my harness, so I haven't got the chance to install it yet actually...
I will take pictures of the deal later today.

I got the Harness and ECU with 4 days.
 

·
Registered
Joined
·
53 Posts
I have the kit ecu and kit harness, kit manual for a 2012 zx10r.

No problems with the install, nothing extra needed.

Good luck!
 

·
Registered
Joined
·
147 Posts
Discussion Starter #7
ACTUALLY there "IS" a sub-harness! After 2 months of the same answer Jason Farrell contacted me and let me know there is a sub-harness and provided the part #. (dont have it on hand) It has the TPS plugs, the coolant temp sensor plug and 1 that plugs into the main harness. the casing around the wires is grey in color. The wiring runs under the Throttlebody between the #3 and 4 cylinder. I hope this helps somebody in the future that trys this build, should someone want to try it!

After that,as of today I was finally able to fire the 10R up for the first time today!
 

·
Registered
Joined
·
581 Posts
ACTUALLY there "IS" a sub-harness! After 2 months of the same answer Jason Farrell contacted me and let me know there is a sub-harness and provided the part #. (dont have it on hand) It has the TPS plugs, the coolant temp sensor plug and 1 that plugs into the main harness. the casing around the wires is grey in color. The wiring runs under the Throttlebody between the #3 and 4 cylinder. I hope this helps somebody in the future that trys this build, should someone want to try it!

After that,as of today I was finally able to fire the 10R up for the first time today!
Huh, guess it's a stock part. Didn't think about how you might need some parts like that since you're building from scratch. If you start off with a stock bike, then you don't have to buy the extra sub-harness to change over to the kit harness/ECU.
 

·
Registered
Joined
·
147 Posts
Discussion Starter #9
Huh, guess it's a stock part. Didn't think about how you might need some parts like that since you're building from scratch. If you start off with a stock bike, then you don't have to buy the extra sub-harness to change over to the kit harness/ECU.
Right. The fact that this is from scratch was what I was stressing, as I knew for a fact no sub-harness existed as far as Kit parts, but was desperately looking for an answer from the stock parts- as it was specific to the TPS sensors. Once I got the picture another guy sent me of his TPS I knew there another harness because of the color the covering the wires wasnt black!
 
1 - 9 of 9 Posts
Top