Kawasaki ZX-10R Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
31 Posts
Discussion Starter · #1 ·
So I recently picked up a ZX-10R with 1500 miles and i'm (mostly) loving it. The only gripes i have so far is the constant loping at idle and jerkiness when cruising at lower speeds, I can generally smooth this out by using higher gears and keeping the rpms lower, but what fun is that? From reading other posts here it seems that the SC Projects CRT exhaust the previous owner installed is the culprit with back pressure being much lower than the stock exhaust. The bike has been flashed with a moore mafia tune as well. Anybody else with this exhaust seem to have solved this issue?

Also should i be worried about the smell of unburnt fuel and constant banging/popping on decel/downshifts? another poster said it could reduce longevity if unburnt fuel is remaining in cylinders and exhaust.
 

· Registered
Joined
·
31 Posts
Discussion Starter · #4 ·
Your bike is running lean as f#ck. A CRT can with decat pipe is basically going from factory cat converter + huge end can to a straight pipe. The mail in flash cannot take care of this: the bike needs to be custom tuned at a dyno. The decel pop is normal and it will be reduced with a tune but it will likely still be there to an extent. Removing the KLEEN system (aka PAIR) will reduce the popping further if you don't like it.
This makes alot of sense. Thank you for the advice.
 

· Registered
Joined
·
31 Posts
Discussion Starter · #13 · (Edited)
I've read that going richer at idle on the IAP map fixes the issue.

There's a thread addressing this very issue, outlining the exact RPM/Throttle range in the IAP map to add fuel.
Any idea where I can find this thread? been looking and I cannot seem to find anything

Edit: here is the thread for anyone wondering Gen 5: 2016-20 - Lurching while cruising
 

· Registered
Joined
·
31 Posts
Discussion Starter · #16 ·
It seems to me that the surging isn't an ongoing issue like the old days with a vacuum leak or the computer hunting with a leaking injector. But the maps that are not linear. Should be an easy fix if I'm right? I noticed mine loops a little at idle when its cold. Once it warms up and maybe after a little ride it smooths out to idle like a dream. Maybe mine is the maps too. Its just setup to run right at proper temp and that's when the engine lines up with the maps?
Perhaps, mine searches for idle when cold and smooths out pretty good once it warms up as well. the main issue I want to rectify is the jerky throttle when cruising in lower gears, Probably will help if i got some sort of tuning software and played with the maps a bit.
 

· Registered
Joined
·
31 Posts
Discussion Starter · #18 ·
I have had the low-rpm throttle issues for quite a while, and its hard to be smooth with it. At this point I've resigned myself to needing a tune for the twitchiness and sudden power-off when holding throttle steady. Kinda disappointing for the price point. My read is part of that is related to the 6k transition in the TBs.
What do you mean by the last part of your post? also are you running the SC projects exhaust as well?
 
1 - 5 of 5 Posts
Top