Kawasaki ZX-10R Forum banner

1 - 10 of 10 Posts

·
Does not drive into smoke
Joined
·
2,156 Posts
Discussion Starter #1
Today I noticed that when the bike was idling (for example waiting at traffic lights), the rpm was somewhat irregular. It sounded as if it was jumping a couple hundred rpm in quick irregular bursts. The bike runs fine otherwise. It's a 2004 ZX10R. FWIW, the default idle is set somewhat high (around 1,500rpm). That's how I got it from the previous owner and I never bothered to lower it.

Any suggestions as to what that could be or what I can do to investigate this further?
 

·
Registered
Joined
·
685 Posts
Today I noticed that when the bike was idling (for example waiting at traffic lights), the rpm was somewhat irregular. It sounded as if it was jumping a couple hundred rpm in quick irregular bursts. The bike runs fine otherwise. It's a 2004 ZX10R. FWIW, the default idle is set somewhat high (around 1,500rpm). That's how I got it from the previous owner and I never bothered to lower it.

Any suggestions as to what that could be or what I can do to investigate this further?
What was the temperature of the bike while it was doing this?
 

·
Registered
Joined
·
3,360 Posts
Is it the lope that you're talking about? I thought most 10R's had this due to the cams...
 

·
Registered
Joined
·
1,361 Posts
my sons zx12 with 13.5 pistons ran very warm in traffic, one sure symptom was idle became erratic, ecu is signaled of high temp and richens fuel to help cool down. experienced this during his dyno tune to such a degree made accurate af ratio difficult. whenever approaching hot, fuel would richen. so, hows your idle when cold or cool?
 

·
Registered
Joined
·
685 Posts
Very hot. Stuck in traffic on a hot day. Close to overheating.
gazx10 is on point with this. My bike ran fine until it warmed up to near 200-210.

I couldn't figure out why my bike was doing it and assumed I had a vacuum leak but that wasn't it. Then I ordered new plugs. While waiting on them, I decided to flush the cooling system and go from Engine Ice to a little bit (about a quart) of G-05, about 5 ozs of RMI-25 and the rest water. Problem went away...

What coolant are you running? When is the last time it was flushed? If it was recent, try burping the system of air. As a last resort, try mostly water with enough coolant for corrosion protection.
 

·
Registered
Joined
·
1,361 Posts
fueling when hot

i had a bike that would run perfect one day and go crazy the next time you rode it, guages would begin flashing, fuel guage would go to full, and temp guage would start climbing all the way to hot and start flashing as a warning of overheating, the hotter it read the worse it ran, at full warning, it was like you pulled the choke on a hot carburated engine, black smoke and flooding with fuel. we ckd that motor numerous times , in that condition, with a infrared heat gun and operating temp. was normal, showing a false reading , but that false signal controlled the fi, richening it. swapped ecu, tps, temp sensor, everything including main wiring and guage harness. it turned out to be a loose connection on the speed sensor that reads frt sprocket causing total mayhem with all the electronics. these new bikes make great power through some complicated engine management, but all interwoven. crazi, you had the answer when you asked the question. been there, got stuck there, and done that. will never forget that repair.
 

·
Does not drive into smoke
Joined
·
2,156 Posts
Discussion Starter #10
so, hows your idle when cold or cool?
When cold/cool/warm the idle is just fine. I lowered it to around 1,250 rpm (middle of the 1k-2k gap).

I will change the coolant to engine ice and see if it makes a difference.
 
1 - 10 of 10 Posts
Top