Kawasaki ZX-10R Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1,146 Posts
Discussion Starter #1
Im still having some issues with my bike after replacing the throttlebodies and map sensor.. I was wondering if anyone has the service manual or knows how to pull the codes from an 06'.. thanks in advance!!
 

·
Registered
Joined
·
2,248 Posts

  • Turn Ignition Switch On
  • Push the mode button to dispaly the odometer
  • Push the reset button for more than 2 seconds
The service code should be displayed on the screen (2 digits).

To get out of self diag mode, hold reset again for 2 more seconds, or switch iginition off....

D
 

·
Registered
Joined
·
1,146 Posts
Discussion Starter #3
BigDally said:

  • Turn Ignition Switch On
  • Push the mode button to dispaly the odometer
  • Push the reset button for more than 2 seconds
The service code should be displayed on the screen (2 digits).

To get out of self diag mode, hold reset again for 2 more seconds, or switch iginition off....

D
oh ok cool.. so its not like jumping a plug on the bike to count the flashing light sequence type deal.. sorry i have never had to pull a code on any of my bikes so im just making sure.. thanks BD!!
 

·
Registered
Joined
·
2,248 Posts
deezuhl said:
oh ok cool.. so its not like jumping a plug on the bike to count the flashing light sequence type deal.. sorry i have never had to pull a code on any of my bikes so im just making sure.. thanks BD!!
Not a prob, just glad I could help someone else for once.... :wink:

D
 

·
Registered
Joined
·
1,146 Posts
Discussion Starter #5
BigDally said:
Not a prob, just glad I could help someone else for once.... :wink:

D

let me ask a dumb question if my bike isnt throwing an FI light anymore after replacing some parts will the code still be stored in the ECU to where you need to reset the ecu somehow.. i tried what you said above and no #' pull up.. probably cause i dont have an FI light anymore.. thanks
 

·
Registered
Joined
·
2,248 Posts
The manual says that if the problem no longer exists (or is repaired), no codes will be displayed. However the problem history is still preserved in the ECU, and can't be erased....

D
 

·
Registered
Joined
·
1,146 Posts
Discussion Starter #7
BigDally said:
The manual says that if the problem no longer exists (or is repaired), no codes will be displayed. However the problem history is still preserved in the ECU, and can't be erased....

D
ok thanks bro!! im not sure if the problem history is still affecting my bike.. i guess i am gonna need to borrow a friends ecu to see if its my ecu thats bad or not..
 

·
Registered
Joined
·
2,248 Posts
deezuhl said:
ok thanks bro!! im not sure if the problem history is still affecting my bike.. i guess i am gonna need to borrow a friends ecu to see if its my ecu thats bad or not..
What's it doing?

D
 

·
Registered
Joined
·
1,146 Posts
Discussion Starter #9
BigDally said:
What's it doing?

D

thanks for asking but trust me it will take me 2 hours to type.. to sum it up the bike on the kit ecu will run perfect for 1 pass and then 2nd pass it pulls timing for some reason dropping the air fuel down to 11's.. the biek could go 194mph on 1st pass then 2nd pass 187, 3rd pass 184, and so on.. motor is perfect and we have done so much in the last 2 weeks to fix it and no resolve. this week i am going to try a new kit ecu and see if its an issue with the ecu.. i orginally thought it was the throttlebodies cause i had an FI light from removing the 2nd butterflies and the bar also.. i just replaced the TBs and the FI light is gone but we have the same issue..
 
1 - 9 of 9 Posts
Top