Kawasaki ZX-10R Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
Hit a bump the other night while riding, and now my low beam HID isn't working. High beam works fine, but if I switch to the low beam, everything goes dark. I checked all the connections and everything seems solid. Ballast problem? Just wondering if anyone has had a similar issue with a quick fix before I buy a new kit. Thanks! It's a Gen 1 BTW.

Sent from my SM-G955U using Tapatalk
 

·
Registered
Joined
·
20 Posts
Discussion Starter #3
Swap the bulbs first to see if that's the problem, then swap the ballast from the other light to see if it's bad. Good luck. I switched to LEDS from HIDS when mine gave me problems.
You like the LEDs? I saw them online and was tossing the idea around.

Sent from my SM-G955U using Tapatalk
 

·
Registered
2016 Kawasaki ZX-10R KRT ABS Edition
Joined
·
682 Posts
I use to have Ballasts go out all the time lol at least once a year, HIDs are incredibly unreliable, but when they do work they're amazing. Only con to the LED is how chunky they are and they may require some heavy modding to the headlight cover (if they're the same kind of LED I run on my FZ09). I ended up just buying those high intensity bulbs you can get at like Meijer for $50 and I haven't had an issue. They're just std powered bulbs so no bs, plug and play, & they should last the life of the bike.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #7
I finally got around to installing the LEDs and they are awesome! Super easy install, good fit, very bright!

Sent from my SM-G955U using Tapatalk
 

·
Registered
Joined
·
1,441 Posts
Thinking about switching to LED's myself too. My damn HID's haven't given me any problems in the past 3 or 4 years that I've had em installed. So I really don't have a reason to switch right now lol.
 

·
Registered
Joined
·
3,833 Posts
I finally got around to installing the LEDs and they are awesome! Super easy install, good fit, very bright!

Sent from my SM-G955U using Tapatalk
Hey wat LED kit you end up going with and how hard was the install? I was tossing the idea going with HIDs seeing how cheap they are but heard LEDs are way better.

Sent from my SCH-I545 using Tapatalk
 

·
Registered
Joined
·
20 Posts
Discussion Starter #12
Hey wat LED kit you end up going with and how hard was the install? I was tossing the idea going with HIDs seeing how cheap they are but heard LEDs are way better.

Sent from my SCH-I545 using Tapatalk
I picked up a set from superbrightleds.com

https://www.superbrightleds.com/vehicle/2005-kawasaki-zx1000-ninja-zx-10r-motorcycle-low-beam-headlight-bulb?make=97&model=3835&scc_id=1943&year=2005

I didn't want to sink a ton of money into one of the revzilla kits, and these got good reviews. I was pleasantly surprised! They work great, are bright as hell, and the install was cake. Just one plug, and secure in place with that wire retaining clip. The clip is kind of a pain in the ass to get in place, but I got it done.

Sent from my SM-G955U using Tapatalk
 

·
Registered
Joined
·
3,833 Posts
I picked up a set from superbrightleds.com

https://www.superbrightleds.com/vehicle/2005-kawasaki-zx1000-ninja-zx-10r-motorcycle-low-beam-headlight-bulb?make=97&model=3835&scc_id=1943&year=2005

I didn't want to sink a ton of money into one of the revzilla kits, and these got good reviews. I was pleasantly surprised! They work great, are bright as hell, and the install was cake. Just one plug, and secure in place with that wire retaining clip. The clip is kind of a pain in the ass to get in place, but I got it done.

Sent from my SM-G955U using Tapatalk
Nice man! Wat color you go with and did you replace both low, high beams? Also would like to see pics of your install because i read installing LEDs require modin the headlight for them to work.

Sent from my SCH-I545 using Tapatalk
 

·
Registered
Joined
·
20 Posts
Discussion Starter #14
Nice man! Wat color you go with and did you replace both low, high beams? Also would like to see pics of your install because i read installing LEDs require modin the headlight for them to work.

Sent from my SCH-I545 using Tapatalk
The color of these is supposed to be the equivalent of 6000k. I replaced the low and high. I didn't have to mod my housings at all, I just cant put the caps on the back (not a big deal to me, I never ride it when there's a chance of rain). I'll grab some pics later today and show you what they look like.

Sent from my SM-G955U using Tapatalk
 

·
Registered
Joined
·
3,833 Posts
The color of these is supposed to be the equivalent of 6000k. I replaced the low and high. I didn't have to mod my housings at all, I just cant put the caps on the back (not a big deal to me, I never ride it when there's a chance of rain). I'll grab some pics later today and show you what they look like.

Sent from my SM-G955U using Tapatalk
Ok i dont ride in the rain unless i get caught in it otw home lol how much brighter are the LEDs vs HIDs you had? Loking forward to the pics

Sent from my SCH-I545 using Tapatalk
 

·
Registered
Joined
·
20 Posts
Discussion Starter #17
Personally, I think they are definitely brighter, but when I yanked out the old HIDs they were mismatched off brand ballasts the previous owner installed. Im slowly but surely fixing all the ghetto rigging the last owner did lol.

You can see they stick out past the housing a little, but I have probably put a hundred miles on the bike since I put them in and they haven't moved at all. The wire retaining clip seems to be working.


Sent from my SM-G955U using Tapatalk
 

·
Registered
Joined
·
3,833 Posts
Personally, I think they are definitely brighter, but when I yanked out the old HIDs they were mismatched off brand ballasts the previous owner installed. Im slowly but surely fixing all the ghetto rigging the last owner did lol.

You can see they stick out past the housing a little, but I have probably put a hundred miles on the bike since I put them in and they haven't moved at all. The wire retaining clip seems to be working.


Sent from my SM-G955U using Tapatalk
Thanks for the pics lights look good man. I know now wat i'll be doing to my gen1 lol

Sent from my SCH-I545 using Tapatalk
 
1 - 20 of 23 Posts
Top