Kawasaki ZX-10R Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
215 Posts
Discussion Starter · #1 ·
So I installed a set of 35W 5000k HID's from DDM tuning into the bike. ESD light is now on. I cant find anything on the forums, nor does the dealership know if this is causing the issue or if its just coincidence and something else is actually wrong with the bike. Any input would be great.
 

·
Registered
Joined
·
153 Posts
The ESD is very sensitive to low voltages or interruptions to power supply. I'd say the HIDs are definitely a factor here. ESD light can be a symptom of a weak battery on the way out. The ABS models have a larger battery but they are still borderline inadequate from the factory. With the extra load of the HIDs, esp when they start up, I'd be wanting a stronger quality battery. If you still have the original battery I'd say that's likely the issue. HIDs place higher strain on the bikes electricals, lots of people seam to like them and that's fine but they are going to increase draw on the system
 

·
Registered
Joined
·
215 Posts
Discussion Starter · #3 ·
Makes sense and that's what I was thinking. Thought going with 35w over the 55w would help this issue. What battery do you suggest?
 

·
Registered
Joined
·
479 Posts
Makes sense and that's what I was thinking. Thought going with 35w over the 55w would help this issue. What battery do you suggest?
Most go with a Shorai Lithium Battery! :thumbsup:
 

·
Registered
Joined
·
215 Posts
Discussion Starter · #5 ·
Perfect, thats what i was looking at. Wanted to make sure before i go and get one.
 
1 - 6 of 6 Posts
Top