Kawasaki ZX-10R Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
707 Posts
Discussion Starter #1
I have done some searches and read through all of them

I just got my TRE for the 06 model and am having some difficulty with reaching and disconnecting the grey connector.

first I have a few questions about removing the tank ( I know it's not needed but the connector seems to be in an impossible position to work with.

Question 1. When I disconnect the fuel line won't all the fuel in the tank drain onto the bike ? if yes what do you guys do to save the bike ?

Question 2. I am looking at the grey connector and I can't figure out how to open it, I know I have to remove two clips but I can't make em out, Any help Pics ?

Thanks
 

·
Registered
Joined
·
203 Posts
Ok answer to 1. just lay the tank side ways on a chair beside you(dont disconect) and to the 2 on the conector get a flat head screw driver and hold the lift lever thing down so it doesnt hold them together (forget about the other one) the put the screw driver in between and move it sideways like turning it. it is a bitch to get it off i went thru it youre gonna sweat like a biatch. remember to disconect the MIDDLE black and yellow wire(theres 2 of them).
 

·
Registered
Joined
·
384 Posts
CMG said:
I have done some searches and read through all of them

I just got my TRE for the 06 model and am having some difficulty with reaching and disconnecting the grey connector.

first I have a few questions about removing the tank ( I know it's not needed but the connector seems to be in an impossible position to work with.

Question 1. When I disconnect the fuel line won't all the fuel in the tank drain onto the bike ? if yes what do you guys do to save the bike ?

Question 2. I am looking at the grey connector and I can't figure out how to open it, I know I have to remove two clips but I can't make em out, Any help Pics ?

Thanks
q1 - no, the valve won't back drain, just whatever is in the line iteslf might come out..

q2 - no pics handy, but with these things, a very small 9jewlers0 flat blade screw diver can be of help. the retaining clips are oddly positioned, as I recall. aNd for Godssakes, searcg 06 TRE and 06 and perhaps my name to makes sure you use the correct wires in that plug, you'll know you got it wrong if your speedo stays at 0 mph permamently after you have done the install.
 

·
Registered
Joined
·
707 Posts
Discussion Starter #4 (Edited)
well I had packed it in but T3 has convinced me to have another go at it,

I am attaching the two pictures can you maybe tell me what to do, I have a feeling that I am interpreting the directions completly wrong.
 

·
Registered
Joined
·
65 Posts
That connector is a real BITCH to get off. Not only does the clips hold it in there but the connector its self is a tight fit.
 

·
Registered
Joined
·
707 Posts
Discussion Starter #6
got it the connectors off, I guess being pissed off is a prerequirement for the Job

had it not been for T3MPO I would have just given up and had a shop do it.

Now I hope the Airbox ain't gonna to be a bitch going back in.
 

·
Registered
Joined
·
214 Posts
DON'T FORGET.... take the middle black and yellow wire out...if you don't..then speedo won't work
 

·
Registered
Joined
·
384 Posts
B1GPAP1 said:
DON'T FORGET.... take the middle black and yellow wire out...if you don't..then speedo won't work
:+1: yes that is the point I was trying to make, using the black/yellow wire from the "outside" of the group of wires (thus making it the easier and more likely, but wrong, choice) will let the TRE work but will lead to speedo not working, which will lead to much swearing as you again remove the tank, the airbox, the connector, etc.

Which is what I had to do, and would hope to save you from having to do.
 

·
Registered
Joined
·
707 Posts
Discussion Starter #9 (Edited)
Thanks guys, I finally finished, It feels like it took the punch out of the bike

don't get me wrong, It still pulls like the same when you get the rev's over 6K

but below that it feels weaker but not jerky anymore (which is what I wanted )

So far I'm happy with the upgrade.
 

·
Registered
Joined
·
384 Posts
CMG said:
Thanks guys, I finally finished, It feels like it took the punch out of the bike

don't get me wrong, It still pulls like the same when you get the rev's over 6K

but below that it feels weaker but not jerky anymore (which is what I wanted )

So far I'm happy with the upgrade.

wow, not how I described it at all, definitely seemed to wake it up in the low revs for me (front wheel coming up sooner in the rev range is how I assessed the impact of the TRE on my 06). But, sounds like you are happy with the result.
 
1 - 10 of 10 Posts
Top