Kawasaki ZX-10R Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
171 Posts
Discussion Starter #1
i have read somewhere someone said something about welding the bottons/basket on the 10s can someone explane this for me plz or send me a link that explanes it . that would be very helpful and thx i also want to know witch gen they were talking about having to do do this on
 

·
Licensed Dist of HaterAde
Joined
·
11,423 Posts
Have ya searched it? if so and no help then i'm sure someone on here will have the info you seek young jedi.....
 

·
Registered
Joined
·
683 Posts
You have to weld the rivets on the back of the clutch basket so that none of them either snaps off or pushes out its holes. I know that this mod is directly related to the 04-07 models. Have no idea if this mod needs to be done to the 08-2010 models. I think that they all have the same exact clutch basket in them. However, i could be wrong but i do think so!!! There are three dark colored rivets on the very back of the clutch basket that needs to be welded if you are going to race any of the ZX-10R's. Especially if your Dragracing it !!! If one of the rivets back out then it can cause severe damage to your engine. Falicon welds them perfectly and precise.
 

·
Registered
Joined
·
171 Posts
Discussion Starter #5
thx very much that helped alot i drag 2 bikes a 05 and a 07 guess i need to do this been lucky so far i guess. is there any pics of this anywhere if so can u get me a link i have looked everywhere cant find anything on it. thx again u have been very help full
 

·
Registered
Joined
·
819 Posts
Pull the outter basket out and flip it over. You will three big round rivet heads. Have someone tig weld them to the primary gear which is the big gear they are already holding down. :thumbsup:

If you need any help you can PM me and I will send you pictures:thumbsup:
 

·
Registered
Joined
·
37 Posts
ok, i did the weld on both of my zx10r. just did another tear down because was hearing noise coming from the clutch basket. after doing my inspection notice that 4 out of the 8 spring on the back side of the basket was loose and 2 was grinding against the casing. so purchase another one off ebay to replace it and once I got the basket in today. that basket have 4 out of the 8 springs on the back side of the basket loose and 2 was grinding the against the casing. well you may say this is normal then, but i dont think so, because the first basket that i blow was making the same noise. i dont think it normal for another part to be rubbing each other in the motor and shows the sign of rubbing.
so have anyone esle have this problem or heard noise in the clutch basket.
 

·
Registered
Joined
·
171 Posts
ok, i did the weld on both of my zx10r. just did another tear down because was hearing noise coming from the clutch basket. after doing my inspection notice that 4 out of the 8 spring on the back side of the basket was loose and 2 was grinding against the casing. so purchase another one off ebay to replace it and once I got the basket in today. that basket have 4 out of the 8 springs on the back side of the basket loose and 2 was grinding the against the casing. well you may say this is normal then, but i dont think so, because the first basket that i blow was making the same noise. i dont think it normal for another part to be rubbing each other in the motor and shows the sign of rubbing.
so have anyone esle have this problem or heard noise in the clutch basket.
My buddies 07 done the same thing, there is a bad groove cut in the cases from this, he caught it just in time. we put in another basket & its been fine every since
 

·
Registered
Joined
·
235 Posts
there are two yellow springs in my basket. they sit directly across from each other. They are the only 2 that move around in the basket. The rivets are welded up though.
 

·
Registered
Joined
·
235 Posts
well, I guess I fall in the basket failure crew now. The bike rode fine this afternoon but started making a knocking type noise when leaned to the right. The noise would go away when stood up or leaned left. The clutch will not release now. It made for a very hard time getting home. Back to square one I guess.
 

·
Registered
Joined
·
235 Posts
Well got the bike fixed. Got to the dyno and the bike only made 201 on the bottle with 100 ft lbs of torque. Didn't matter what nitrous pill we put in it 201 was it. I think my nozzles in the air box are maxed out due to my line going to it not being cold. If the line goin to the nozzles isn't cold I don't see if flowing enough.
 

·
Registered
Joined
·
179 Posts
I would like to see this mod pics as well. Sounds like something I need to do soon. i run my 05 with nos often and do not want to have a major issue arise. (Running 8.90's and I am 205 in leathers:)
 
1 - 20 of 23 Posts
Top