Kawasaki ZX-10R Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
836 Posts
Discussion Starter #1 (Edited)
Rough idle when it's cold or run on 2-3 spark plugs

I'm think of calling this bike belzébuth....

Well just rebuilt motor, put together and everything seem to work fine, except for a cut wire to the speedometer (repair now).

NOW it begin to do another funny thing.

No error code at all so couldn't be electric of any kind ?

Well when I started the bike and the motor are cold, it seem to work on one or two pistons, when it heats up everything work fine.

As I'm tell no error code at all.

So I suspect maybe

1- Spark plugs (but why they are O.K when it's hot ????)
2- Maybe a bad clearance on the valves ????? (should do all the time cold hot etc...)
3- Vacuum hoses somewhere in the throtle body (but ehhhh it should be more loose with heat)
4- Something related with the fuel pump (but it's work fine when hot and no jerking off or something), and when I check the pump

5- Some loose wires (but why just do this when it's cold, but not when it's hot ???)

6- Bad gas ?

7- I don't check if their the right voltage to the battery (but it's start well with good cranking)


8- Mods are: PC III (I reload the map yestuerday in it)
Intake cam 106 degrees exhaust 102 degrees. Thin head gasket.
Double fan for cooling the beast (when you increase the compression heat coming up with it.

Before I dig in the motor or the wires, somebody got this weird stuff happen to him ?


And I think something like Belzébuth for the name of this bike.......>:)
 

·
Registered
Joined
·
836 Posts
Discussion Starter #2
Bought injector cleaner. I will give a try tonight and see if it's better.

Bad coil or spark plugs my next guess.
 

·
Registered
Joined
·
42 Posts
I doubt injector cleaner would do anything. Id start and let it cycle a dozen times. Then pull the plugs and it may show which cylinder maybe the issue and trace it from there.
 

·
Registered
Joined
·
112 Posts
Have you pulled / bypassed the PC3?
double check the ground wire connections.

No error code only means no sensors are out of spec.; that doesn’t mean there isn’t a problem. The bike only has so many sensors and the computer only so much processing power.

My ZX11 did this when the plugs got fouled - thanks to my fancy carbs; it was a twofold problem; the carbs weren’t properly fueling at low speed and as a result the plugs would foul after some riding in traffic, because I’d never get any high rpms. It would start, run and sound like a worn out Volkswagen or Subaru, then when it got warm it seemed to run fine - even at low rpm. put her to sleep, come back the next day and the pattern repeated. I should say, at the time, my ZX11 had 1206cc, and there wasn’t anything stock within the motor at all except the cylinder head and valves. The flat slide carbs simply could not be set and forgotten. You should have no such issue with a fuel injected bike, unless the injectors and field bodies are dirty; as in, they sat with drying fuel while the motor was rebuild or something.

From what you describe, I would focus on the fueling.

Good luck.
 

·
Registered
Joined
·
2,344 Posts
Make sure the bike is cold, crank it up and then spray water onto the exhaust manifold runner, The ones firing will evaporate quickly and if not firing it will not evaporate. That will at least get you started to see which cylinder is and isn't firing...then you can swap coils, wires etc..to narrow down if it's a part failure or something internal.
 

·
Registered
Joined
·
836 Posts
Discussion Starter #7
Problem solved.

Stupid water in the gas.

The vent who are under the gas capon the body of the tank and who are there to evacuate any kind of liquid including water was plugged. Result are each time bike sleep outside water fill up under the gas cap and found it's way through the gas tank and contaminated the gas ....results water in the gas. Don't take a lot to make the bike run like shit.

Problem are resolved now.

Last time it rains a lot so about 1 liter of water was mixed with gas when I empty up the tank.
 
1 - 7 of 7 Posts
Top