Kawasaki ZX-10R Forum banner

1 - 4 of 4 Posts

·
Dont mess wit White Ninja
Joined
·
5,932 Posts
Discussion Starter #1
About to crack open and start on a rebuild I picked up.

06 zx10r 15k miles

The owner dumped it grabbing to much front break. Result=huge damage!
My question to anyone/2nd gen owner is he broke the plug off the harness that leads to the cluster. I traced out the line and it seems he will have to replace the harness. My question is does the front end of the harness connect to a sub-harness or is it one piece on this 2nd gen. Just wondering if I'll have to pull the hole harness or not. Thanks guys:eek:ccasion1
 

·
Registered
Joined
·
1,755 Posts
Just wondering... Can you just buy a new plug and redo the wiring for it? Post a picture of the bike if you can please.
 

·
Dont mess wit White Ninja
Joined
·
5,932 Posts
Discussion Starter #3
Just wondering... Can you just buy a new plug and redo the wiring for it? Post a picture of the bike if you can please.
See that was another thing, I was just debating on splicing into the harness with a new plug and solder/tape it up...


Guess no one has a answer out of a million people here:crackup:
 

·
Dont mess wit White Ninja
Joined
·
5,932 Posts
Discussion Starter #4
So everyone knows on this site for anyone who needs to do a harness swap!

First the harness on these 2nd gens are ONE piece so if something happens you have to replace the hole thing! Did I= NOPE! I spliced in the new plug and solder/taped it up and YAY the cluster works!
 
1 - 4 of 4 Posts
Top