Kawasaki ZX-10R Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
143 Posts
Discussion Starter #1
I noticed more so when going round a fast sweeping bend, the front feels every bump and feels like its jumping up/down quickly or I am fighting to hold on. Perhaps skipping is the word. Now the front has stiff suspension (OEM) anyway.

Do you think I need to adjust my rebound or compression. Settings are :

Front rebound = 9 clicks from clockwise full in
Front compression = 7 clicks from clockwise full in
 

·
Registered
Joined
·
1,667 Posts
I noticed more so when going round a fast sweeping bend, the front feels every bump and feels like its jumping up/down quickly or I am fighting to hold on. Perhaps skipping is the word. Now the front has stiff suspension (OEM) anyway.

Do you think I need to adjust my rebound or compression. Settings are :

Front rebound = 9 clicks from clockwise full in
Front compression = 7 clicks from clockwise full in
Start at the beginning. What are your spring rates? How much do you weigh? First thing you need to do is get your spring rate right, which may mean new springs (not too expensive). Then get your sag and baseline suspension settings done. Then go ride again and see how it feels and make adjustments from there.

I also recommend you check and adjust your steering head bearings as even a slight looseness can create all kinds of handling problems.

No way you can tell whether it's spring rate, rebound, compression or whatnot from your post. You have to start from the baseline and then make changes after it's set up right.

Also the rear figures into it big time. So do the rear too. Then go out and start fine-tuning.
 
1 - 4 of 4 Posts
Top