Kawasaki ZX-10R Forum banner

1 - 20 of 41 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Hey guys and gals.....just got the bike back after 2 weeks of the dealer trying to find oil leak and then get the parts. The oil was a constant splatter on the exhaust until finally it was dripping off the engine and getting on the fairings. Apparantly it was the O-ring where the starter goes into the engine that was leaking. Put about 50 miles on it after getting back with no leaks. Just an FYI to maybe save time if anyone else has similar leak. Ride safe!
 

·
Registered
Joined
·
22 Posts
Discussion Starter #4
So quick update, bike went back to shop with leak from same spot. They replaced starter this time. Fingers crossed!
 

·
Registered
Joined
·
414 Posts
Keep us updated! My first gen. 4 had a bad leak towards the back of the motor. Never did find out where it was coming from. Is that warrantable?
 

·
Registered
Joined
·
22 Posts
Discussion Starter #6
So picked up the bike, put about 50 miles on it and spewing oil again.
They are picking it up Monday. Apparently only thing left is to replace the crankcase.
So far all been warranty as bike is only 3 months old.
 

·
Registered
Joined
·
5 Posts
been there done that

I feel your pain, after my 600 mile service my bike had the oil leak described, I took it in the dealer said it was leaking from one of the cases......ok. I get it back and 700 miles later....oil leak. Take it back, wait two weeks..... they said it was a leak at the oil pan gasket. I got the bike back on the 23 June.......no leaks yet. But I need to take it out and ride it hard to make sure. Stay tuned for updates.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #8
Please do keep me posted. They've had my bike now for another week. Still waiting for parts. Fighting with kawi to replace bike. 3 months old and they've had it as much as I have. Their customer service reps are extremely rude btw. I love my bike.....just them tearing it apart and rebuilding engine after 3 months is not acceptable to me. I'll keep you up to date.
 

·
Registered
Joined
·
330 Posts
I'd look into the lemon laws for your state and see if the bike can't be replaced for repeatedly having the same problem. Bad customer service seems to be the general rule for most Jap bike dealers. They should take some lessons from how most BMW motorcycle dealers treat their customers.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #10
So I still don't have the bike back. They have now had it for over a month out of 3 months of ownership.
I requested a trade assist to replace the bike as this doesn't cost anyone anything. Kawasaki refused.
There is no motorcycle lemon law in Florida. This basically leaves me no option other than to sue Kasasaki under Federal Magnuson Moss warranty act. I have done everything I can to avoid this. Corporations are so blind at times.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #15 (Edited)
Seems that either Kawasaki is going to have a recall or they are trying to avoid one. Still don't have bike back. Kawasaki customer service is absolutely shit. They've had my bike for month and a half out of 4 months of ownership. They don't care. Story so far is the cases are porous. Their fix is to remove starter and epoxy the porous area of the case. However, the new case was missing the jets for number 1 piston and the oil pump chain. So going to be another 2 weeks before I might have her back. Time to get the lawyer involved.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #17
Riva. Tbh they have been fantastic throughout the whole thing. I'm not convinced a lesser tech would have noticed the missing oil jets. My beef is squarely on Kawasaki.
 

·
Speed Freak
Joined
·
12,730 Posts
Got ya, yeah was wodnering if it was BMS of lauderdale or davie, I could have put a call in and see if they had any more info for ya. I work at BMS of palm beach.

Sounds like you have a hell of a problem, sorry to hear.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #19
Thanks bro. I actually work at Jag down the street from you. I hope the problem is only with mine so the rest of you guys don't have to deal with the same shit I am.
 

·
Speed Freak
Joined
·
12,730 Posts
Nice, yeah we havnt had to do anything crazy like that on any of the new 10r's here :-/

Sounds like you have one of those Friday built motors lol....
 
1 - 20 of 41 Posts
Top