Kawasaki ZX-10R Forum banner

1 - 3 of 3 Posts

·
Newfie Bullet
Joined
·
2,341 Posts
Discussion Starter #1
OK i have a gen 2 with electrical or some sorta thermal issue..

My bike has sat for almost a yr now with the odd start up battery replacement and now trickle charge to keep battery in good condition..

I posted here that bike just up and quits in another thread and netural lite flickers with no power to starter switch..

I just took the battery outta my gen3 and she sparked rite up..

I thought everything was fine till she hit 100cel or 210 f...She quit again..Fans were running and all but engine flat out died...I shut the key off and waited again for 30 seconds or less and turned key on and she sparked right up and died 10 seconds later..Yet again the netural light was flickering ever so slightly when revved a lil..

I took off that lil ceramic switch rite behind the front sprocket and cleaned the brass connections and the two lil pins(spring loaded)...

Is there a thermal safety/overheat switch or somethin thats affecting the bike or is it possible that the netural switch(round ceramic electrical behind the front sprocket)is heat sentitive...Kick stand switch maybe??

I need some suggestions,cause i may have a buyer for the bike..Im stumped..
 

·
Registered
Joined
·
162 Posts
With the neutral light flickering like that it sounds like a charging issue, its odd when the fans came on the engine died, almost like it was too much current draw and killed the system. Is the batt staying charged?
 

·
Newfie Bullet
Joined
·
2,341 Posts
Discussion Starter #3
The netural light usually flickers ever so slightly when i rev it up...I left my gi pro tre with gear indicator hooked up over the summer an all but a new battery went in it last yr..So i got my battery from my gen 3 in it now..Old one is toast just gonna get a warrenty done on that..
It doesnt quit when fan turns on but rite around 210 f(by that time fan is on)
It will quit suddenly and then i can shut key off and back on and it will run for a sec..
I notice that i jiggle the shifter and the net light comes off and on...Im thinkin its a netural switch but i dont understand why it quits when up to the 200 range..

Im not sure what im lookin for in the netural switch..As in my 1st post im guessin it the electrical ceramic thingy just back from front sprocket..
 
1 - 3 of 3 Posts
Top